source: npl/X/cairo/cairo.SlackBuild.orig @ 26ffad7

Last change on this file since 26ffad7 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 3.9 KB
Line 
1#!/bin/sh
2
3# Copyright 2008, 2009, 2010, 2011, 2013, 2015  Patrick J. Volkerding, Sebeka, MN, USA
4# All rights reserved.
5#
6# Redistribution and use of this script, with or without modification, is
7# permitted provided that the following conditions are met:
8#
9# 1. Redistributions of this script must retain the above copyright
10#    notice, this list of conditions and the following disclaimer.
11#
12#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
13#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
14#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
15#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
16#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
17#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
18#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
19#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
20#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
21#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22
23
24PKGNAM=cairo
25VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
26BUILD=${BUILD:-1}
27
28# Automatically determine the architecture we're building on:
29if [ -z "$ARCH" ]; then
30  case "$( uname -m )" in
31    i?86) export ARCH=i586 ;;
32    arm*) export ARCH=arm ;;
33    # Unless $ARCH is already set, use uname -m for all other archs:
34       *) export ARCH=$( uname -m ) ;;
35  esac
36fi
37
38NUMJOBS=${NUMJOBS:-" -j7 "}
39
40if [ "$ARCH" = "i586" ]; then
41  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
42  LIBDIRSUFFIX=""
43elif [ "$ARCH" = "s390" ]; then
44  SLKCFLAGS="-O2"
45  LIBDIRSUFFIX=""
46elif [ "$ARCH" = "x86_64" ]; then
47  SLKCFLAGS="-O2 -fPIC"
48  LIBDIRSUFFIX="64"
49else
50  SLKCFLAGS="-O2"
51  LIBDIRSUFFIX=""
52fi
53
54CWD=$(pwd)
55TMP=${TMP:-/tmp}
56PKG=$TMP/package-$PKGNAM
57rm -rf $PKG
58mkdir -p $TMP $PKG
59
60cd $TMP
61rm -rf $PKGNAM-$VERSION
62tar xvf $CWD/$PKGNAM-$VERSION.tar.?z* || exit 1
63cd $PKGNAM-$VERSION
64chown -R root:root .
65find . \
66  \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
67  -exec chmod 755 {} \; -o \
68  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
69  -exec chmod 644 {} \;
70
71zcat $CWD/cairo.c088ba1faab9579efdaed7a524124901a17801b0.diff.gz | patch -p1 --verbose || exit 1
72
73CFLAGS="$SLKCFLAGS" \
74./configure \
75  --prefix=/usr \
76  --libdir=/usr/lib${LIBDIRSUFFIX} \
77  --mandir=/usr/man \
78  --sysconfdir=/etc \
79  --disable-gtk-doc \
80  --disable-quartz \
81  --disable-static \
82  --disable-win32 \
83  --disable-trace \
84  --enable-xlib \
85  --enable-xcb \
86  --enable-ps \
87  --enable-pdf \
88  --enable-svg \
89  --enable-tee \
90  --enable-ft \
91  --disable-gl \
92  --enable-gobject \
93  --enable-xml \
94  --build=$ARCH-slackware-linux
95
96# None of these are 'stable' yet...
97#  --enable-qt \
98#  --enable-drm \
99
100# Not sure if these two are needed / useful yet; --enable-xcb is now default
101#  --enable-xcb-shm \
102#  ^^ may cause GTK+3 instability
103#  --enable-xlib-xcb \
104#  ^^  this one caused a GIMP slowdown
105
106# Skipping this, because it causes a dependency on the specific
107# version of binutils installed at compile time:
108#  --enable-trace
109
110make $NUMJOBS || make || exit 1
111make install DESTDIR=$PKG
112
113find $PKG | xargs file | grep -e "executable" -e "shared object" \
114  | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
115
116mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
117cp -a \
118  AUTHORS BIBLIOGRAPHY BUGS CODING_STYLE COPYING* HACKING NEWS PORTING_GUIDE README RELEASING \
119  $PKG/usr/doc/$PKGNAM-$VERSION
120( cd $PKG/usr/doc/$PKGNAM-$VERSION ; ln -sf /usr/share/gtk-doc/html/cairo html )
121
122# We do not need the entire NEWS file.
123if [ -r NEWS ]; then
124  DOCSDIR=$(echo $PKG/usr/doc/*-$VERSION)
125  cat NEWS | head -n 1000 > $DOCSDIR/NEWS
126  touch -r NEWS $DOCSDIR/NEWS
127fi
128
129mkdir -p $PKG/install
130cat $CWD/slack-desc > $PKG/install/slack-desc
131
132cd $PKG
133/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz
134
Note: See TracBrowser for help on using the repository browser.