source: npl/X/glib/glib.SlackBuild @ 26ffad7

Last change on this file since 26ffad7 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.8 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#Strict build-dependencies.
8#Only use when really neccesary, this will rebuild our package if the dependencie has changed:
9##DEP:linux
10##DEP:linux_src
11
12#Looese build-dependencies.
13#Use this to specify the packages that are required to build our package:
14##NEED:libpng
15##NEED:xorg_proto
16##NEED:xorg_lib
17##NEED:freetype2
18##NEED:fontconfig
19##NEED:expat
20
21
22#######Essential package info.
23#Change these if autodetection fails.
24
25#Name of the Syn-3 package that we are going to create
26NAME=`basename $0|sed 's/.SlackBuild//'`
27
28#Archive of the sourcefiles to unpack
29SRC_ARC=`ls *.tar.gz`
30
31#Version of the sourcefiles
32VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/.tar.gz//g'`
33
34#Directory of the sourcefiles to build (after optional unpacking)
35SRC_DIR=`echo $SRC_ARC| sed 's/.tar.gz//g'`
36
37#Architecture that the created binaries run on.
38#Use noarch for scripts.
39ARCH=`arch`
40
41
42########Build and create the pacakge.
43#Uncomment the stuff that you dont want or need
44
45#Unpack source
46#(uncomment if not needed)
47syn3_unpack $SRC_ARC || exit 1
48
49#build and install sourcefiles
50#(use one of the other syn3_build_* scripts when needed)
51export CONFIGURE_OPTS=""
52export MAKE_OPTS=""
53#export NOTEST=1
54syn3_build_automake $SRC_DIR /tmp/pkg || exit 1
55
56#strip bins and other stuff
57syn3_strip /tmp/pkg || exit 1
58
59#move development stuff and create seperate development package
60syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
61syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
62
63#make main package
64syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
65
66
Note: See TracBrowser for help on using the repository browser.