source: npl/X/glib2/glib2.SlackBuild.orig

Last change on this file was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 4.4 KB
Line 
1#!/bin/sh
2
3# Copyright 2008, 2009, 2010, 2011, 2015  Patrick J. Volkerding, Sebeka, MN, USA
4# All rights reserved.
5#
6# Redistribution and use of this script, with or without modification, is
7# permitted provided that the following conditions are met:
8#
9# 1. Redistributions of this script must retain the above copyright
10#    notice, this list of conditions and the following disclaimer.
11#
12#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
13#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
14#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
15#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
16#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
17#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
18#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
19#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
20#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
21#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22
23
24VERSION=${VERSION:-$(echo glib-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
25BUILD=${BUILD:-2}
26
27NUMJOBS=${NUMJOBS:-" -j7 "}
28
29# Automatically determine the architecture we're building on:
30if [ -z "$ARCH" ]; then
31  case "$( uname -m )" in
32    i?86) export ARCH=i586 ;;
33    arm*) export ARCH=arm ;;
34    # Unless $ARCH is already set, use uname -m for all other archs:
35       *) export ARCH=$( uname -m ) ;;
36  esac
37fi
38
39CWD=$(pwd)
40TMP=${TMP:-/tmp}
41PKG=$TMP/package-glib2
42
43if [ "$ARCH" = "i586" ]; then
44  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
45  LIBDIRSUFFIX=""
46elif [ "$ARCH" = "s390" ]; then
47  SLKCFLAGS="-O2"
48  LIBDIRSUFFIX=""
49elif [ "$ARCH" = "x86_64" ]; then
50  SLKCFLAGS="-O2 -fPIC"
51  LIBDIRSUFFIX="64"
52else
53  SLKCFLAGS="-O2"
54  LIBDIRSUFFIX=""
55fi
56
57rm -rf $PKG
58mkdir -p $TMP $PKG/usr
59cd $TMP
60rm -rf glib-$VERSION
61tar xvf $CWD/glib-$VERSION.tar.?z* || exit 1
62cd glib-$VERSION || exit 1
63
64chown -R root:root .
65find . \
66 \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
67 -exec chmod 755 {} \; -o \
68 \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
69 -exec chmod 644 {} \;
70
71# Silly upstream, using the bleeding edge.  Reconf:
72#autoreconf --force --install
73
74patch -p1 < $CWD/0001-GDBusProxy-Fix-a-memory-leak-during-initialization.patch || exit 1
75
76CFLAGS="$SLKCFLAGS" \
77./configure \
78  --prefix=/usr \
79  --libdir=/usr/lib${LIBDIRSUFFIX} \
80  --sysconfdir=/etc \
81  --mandir=/usr/man \
82  --disable-libelf \
83  --build=$ARCH-slackware-linux || exit 1
84
85make $NUMJOBS || make || exit 1
86make install DESTDIR=$PKG || exit 1
87
88# Install profile scripts:
89mkdir -p $PKG/etc/profile.d/
90cp -a $CWD/libglib2.{csh,sh} $PKG/etc/profile.d/
91chown root:root $PKG/etc/profile.d/*
92chmod 755 $PKG/etc/profile.d/*
93mv $PKG/etc/profile.d/libglib2.csh $PKG/etc/profile.d/libglib2.csh.new
94mv $PKG/etc/profile.d/libglib2.sh $PKG/etc/profile.d/libglib2.sh.new
95
96find $PKG | xargs file | grep -e "executable" -e "shared object" \
97  | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
98
99# Compress and link manpages, if any:
100if [ -d $PKG/usr/man ]; then
101  ( cd $PKG/usr/man
102    for manpagedir in $(find . -type d -name "man*") ; do
103      ( cd $manpagedir
104        for eachpage in $( find . -type l -maxdepth 1) ; do
105          ln -s $( readlink $eachpage ).gz $eachpage.gz
106          rm $eachpage
107        done
108        gzip -9 *.?
109      )
110    done
111  )
112fi
113
114mkdir -p $PKG/usr/doc/glib-$VERSION
115cp -a \
116  AUTHORS COPYING* NEWS README* \
117  $PKG/usr/doc/glib-$VERSION
118  rm -f $PKG/usr/doc/glib-$VERSION/README.{in,win32}
119( cd $PKG/usr/doc/glib-$VERSION ; ln -s /usr/share/gtk-doc/html/gobject html )
120
121# If there's a ChangeLog, installing at least part of the recent history
122# is useful, but don't let it get totally out of control:
123if [ -r ChangeLog ]; then
124  DOCSDIR=$(echo $PKG/usr/doc/*-$VERSION)
125  cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
126  touch -r ChangeLog $DOCSDIR/ChangeLog
127fi
128
129# Trim down bloated NEWS file:
130if [ -r NEWS ]; then
131  DOCSDIR=$(echo $PKG/usr/doc/*-$VERSION)
132  cat NEWS | head -n 1000 > $DOCSDIR/NEWS
133  touch -r NEWS $DOCSDIR/NEWS
134fi
135
136mkdir -p $PKG/install
137cat $CWD/slack-desc > $PKG/install/slack-desc
138zcat $CWD/doinst.sh.gz | sed "s,@LIBDIR@,/usr/lib${LIBDIRSUFFIX}," > $PKG/install/doinst.sh
139
140cd $PKG
141/sbin/makepkg -l y -c n --prepend $TMP/glib2-$VERSION-$ARCH-$BUILD.txz
142
Note: See TracBrowser for help on using the repository browser.