source: npl/X/gtk+/gtk+.SlackBuild.orig

Last change on this file was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 3.9 KB
Line 
1#!/bin/sh
2
3# Copyright 2006, 2007, 2008, 2009  Patrick J. Volkerding, Sebeka, MN, USA
4# All rights reserved.
5#
6# Redistribution and use of this script, with or without modification, is
7# permitted provided that the following conditions are met:
8#
9# 1. Redistributions of this script must retain the above copyright
10#    notice, this list of conditions and the following disclaimer.
11#
12#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
13#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
14#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
15#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
16#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
17#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
18#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
19#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
20#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
21#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22
23
24PKGNAM=gtk+
25VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
26BUILD=${BUILD:-5}
27
28# Automatically determine the architecture we're building on:
29if [ -z "$ARCH" ]; then
30  case "$( uname -m )" in
31    i?86) export ARCH=i486 ;;
32    arm*) export ARCH=arm ;;
33    # Unless $ARCH is already set, use uname -m for all other archs:
34       *) export ARCH=$( uname -m ) ;;
35  esac
36fi
37
38NUMJOBS=${NUMJOBS:-" -j7 "}
39
40CWD=$(pwd)
41TMP=${TMP:-/tmp}
42PKG=$TMP/package-${PKGNAM}
43rm -rf $PKG
44mkdir -p $TMP $PKG
45
46if [ "$ARCH" = "i486" ]; then
47  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
48  LIBDIRSUFFIX=""
49elif [ "$ARCH" = "s390" ]; then
50  SLKCFLAGS="-O2"
51  LIBDIRSUFFIX=""
52elif [ "$ARCH" = "x86_64" ]; then
53  SLKCFLAGS="-O2 -fPIC"
54  LIBDIRSUFFIX="64"
55else
56  SLKCFLAGS="-O2"
57  LIBDIRSUFFIX=""
58fi
59
60cd $TMP
61rm -rf ${PKGNAM}-${VERSION}
62tar xvf $CWD/${PKGNAM}-$VERSION.tar.?z* || exit 1
63cd ${PKGNAM}-$VERSION
64
65bzcat $CWD/gtk+1.2_1.2.10-18.diff.bz2 | patch -p1 --verbose || exit 1
66
67# Make sure ownerships and permissions are sane:
68chown -R root:root .
69find . \
70  \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
71  -exec chmod 755 {} \; -o \
72  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
73  -exec chmod 644 {} \;
74
75# The original config.{guess,sub} do not work on x86_64
76#cp /usr/share/libtool/config.{guess,sub} .             # libtool-1.x
77#cp /usr/share/libtool/config/config.{guess,sub} .       # libtool-2.x
78
79# Configure:
80CFLAGS="$SLKCFLAGS" \
81CXXFLAGS="$SLKCFLAGS" \
82./configure \
83  --prefix=/usr \
84  --libdir=/usr/lib${LIBDIRSUFFIX} \
85  --sysconfdir=/etc \
86  --with-glib-prefix=/usr \
87  --mandir=/usr/man \
88  --program-prefix= \
89  --program-suffix= \
90  --build=$ARCH-slackware-linux
91
92# Build and install:
93make $NUMJOBS || make || exit 1
94make install DESTDIR=$PKG || exit 1
95
96# Strip binaries:
97find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
98  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
99
100# Compress and link manpages, if any:
101if [ -d $PKG/usr/man ]; then
102  ( cd $PKG/usr/man
103    for manpagedir in $(find . -type d -name "man*") ; do
104      ( cd $manpagedir
105        for eachpage in $( find . -type l -maxdepth 1) ; do
106          ln -s $( readlink $eachpage ).gz $eachpage.gz
107          rm $eachpage
108        done
109        gzip -9 *.*
110      )
111    done
112  )
113fi
114
115# Compress info files, if any:
116if [ -d $PKG/usr/info ]; then
117  ( cd $PKG/usr/info
118    rm -f dir
119    gzip -9 *
120  )
121fi
122
123# Add a documentation directory:
124mkdir -p $PKG/usr/doc/${PKGNAM}-$VERSION
125cp -a \
126  ABOUT-NLS AUTHORS COPYING* HACKING INSTALL NEWS \
127  README* TODO \
128  $PKG/usr/doc/${PKGNAM}-$VERSION
129
130mkdir -p $PKG/install
131#zcat $CWD/doinst.sh.gz > $PKG/install/doinst.sh
132cat $CWD/slack-desc > $PKG/install/slack-desc
133
134cd $PKG
135/sbin/makepkg -l y -c n $TMP/${PKGNAM}-$VERSION-$ARCH-$BUILD.txz
136
Note: See TracBrowser for help on using the repository browser.