source: npl/X/mkxf86config/mkxf86config.SlackBuild

Last change on this file was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 688 bytes
Line 
1#!/bin/sh
2
3NAME=mkxf86config
4VERSION=0.9.3
5CWD=`pwd`
6
7PKG=/tmp/package-mkxf86config
8
9tar -jxvf $NAME-$VERSION.tar.bz2
10
11mkdir -p $PKG/sbin $PKG/usr/sbin $PKG/etc/X11
12
13# copy de gentoo functions file in de package
14mv $CWD/functions.sh $PKG/sbin
15chmod 755 $PKG/sbin/functions.sh || exit 1
16
17# Stift de rest van de bende in de package...
18cd $NAME-$VERSION
19zcat $CWD/speedo.diff.gz | patch -p0 || exit 1
20mv mkxf86config.sh $PKG/usr/sbin/
21chmod 755 $PKG/usr/sbin/mkxf86config.sh || exit 1
22mv xorg.conf.in $PKG/etc/X11/
23chmod 644 $PKG/etc/X11/xorg.conf.in || exit 1
24
25cd $PKG
26makepkg -l y -c n $CWD/$NAME.pkg || exit 1
27echo $VERSION > $CWD/$NAME.version || exit 1
28arch > $CWD/$NAME.arch || exit 1
Note: See TracBrowser for help on using the repository browser.