source: npl/X/mscorefonts/mscorefonts.SlackBuild

Last change on this file was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.2 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#Strict build-dependencies.
8#Only use when really neccesary, this will rebuild our package if the dependencie has changed:
9##DEP:linux
10##DEP:linux_src
11
12#Loose build-dependencies.
13#Use this to specify the packages that are required to build our package:
14##NEED:libcairo
15##NEED:glib
16##NEED:gtk+
17##NEED:glib2
18##NEED:gtk+2
19##NEED:xorg_lib
20##NEED:xorg_proto
21#DEP:cabextract
22
23#######Essential package info.
24#Change these if autodetection fails.
25
26#Name of the Syn-3 package that we are going to create
27NAME=`basename $0|sed 's/.SlackBuild//'`
28
29
30#Version of the sourcefiles
31VER=1.0
32
33#Architecture that the created binaries run on.
34#Use noarch for scripts.
35ARCH=noarch
36
37mkdir fonts
38cd fonts
39cabextract ../*.exe || exit 1
40mkdir -p /tmp/pkg/usr/share/fonts/mscorefonts
41cp *.ttf *.TTF /tmp/pkg/usr/share/fonts/mscorefonts || exit 1
42cd ..
43
44#make main package
45syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
46
47
Note: See TracBrowser for help on using the repository browser.