source: npl/X/pango/pango.SlackBuild.orig @ f9ce31e

perl-5.22
Last change on this file since f9ce31e was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 3.5 KB
RevLine 
[c5c522c]1#!/bin/sh
2
3# Copyright 2008, 2009, 2010, 2011, 2015  Patrick J. Volkerding, Sebeka, MN, USA
4# All rights reserved.
5#
6# Redistribution and use of this script, with or without modification, is
7# permitted provided that the following conditions are met:
8#
9# 1. Redistributions of this script must retain the above copyright
10#    notice, this list of conditions and the following disclaimer.
11#
12#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
13#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
14#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
15#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
16#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
17#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
18#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
19#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
20#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
21#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22
23PKGNAM=pango
24VERSION=${VERSION:-$(echo pango-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
25BUILD=${BUILD:-1}
26
27# Automatically determine the architecture we're building on:
28if [ -z "$ARCH" ]; then
29  case "$( uname -m )" in
30    i?86) export ARCH=i586 ;;
31    arm*) export ARCH=arm ;;
32    # Unless $ARCH is already set, use uname -m for all other archs:
33       *) export ARCH=$( uname -m ) ;;
34  esac
35fi
36
37if [ "$ARCH" = "i586" ]; then
38  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
39  LIBDIRSUFFIX=""
40elif [ "$ARCH" = "s390" ]; then
41  SLKCFLAGS="-O2"
42  LIBDIRSUFFIX=""
43elif [ "$ARCH" = "x86_64" ]; then
44  SLKCFLAGS="-O2 -fPIC"
45  LIBDIRSUFFIX="64"
46else
47  SLKCFLAGS="-O2"
48  LIBDIRSUFFIX=""
49fi
50
51NUMJOBS=${NUMJOBS:-" -j7 "}
52
53CWD=$(pwd)
54TMP=${TMP:-/tmp}
55PKG=$TMP/package-pango
56
57rm -rf $PKG
58mkdir -p $TMP $PKG/usr
59cd $TMP
60rm -rf pango-$VERSION
61tar xvf $CWD/pango-$VERSION.tar.?z* || exit 1
62
63cd pango-$VERSION
64
65chown -R root:root .
66find . \
67  \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
68  -exec chmod 755 {} \; -o \
69  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
70  -exec chmod 644 {} \;
71
72CFLAGS="$SLKCFLAGS" \
73./configure \
74  --prefix=/usr \
75  --libdir=/usr/lib${LIBDIRSUFFIX} \
76  --sysconfdir=/etc \
77  --mandir=/usr/man \
78  --docdir=/usr/doc/pango-$VERSION \
79  --with-xft \
80  --build=$ARCH-slackware-linux \
81  --host=$ARCH-slackware-linux \
82  --target=$ARCH-slackware-linux
83
84make $NUMJOBS || make || exit 1
85make install DESTDIR=$PKG || exit 1
86
87# Do not remove pangox.aliases
88#rm -f $PKG/etc/pango/pango.modules
89#mkdir -p $PKG/etc/pango/$host
90#touch $PKG/etc/pango/$host/pango.modules
91
92find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
93  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
94
95# Compress and link manpages, if any:
96if [ -d $PKG/usr/man ]; then
97  ( cd $PKG/usr/man
98    for manpagedir in $(find . -type d -name "man*") ; do
99      ( cd $manpagedir
100        for eachpage in $( find . -type l -maxdepth 1) ; do
101          ln -s $( readlink $eachpage ).gz $eachpage.gz
102          rm $eachpage
103        done
104        gzip -9 *.?
105      )
106    done
107  )
108fi
109
110mkdir -p $PKG/usr/doc/pango-$VERSION
111cp -a \
112  AUTHORS COPYING* NEWS README* TODO \
113  $PKG/usr/doc/pango-$VERSION
114ln -s /usr/share/gtk-doc/html/pango $PKG/usr/doc/pango-$VERSION/html
115
116mkdir -p $PKG/install
117cat $CWD/slack-desc > $PKG/install/slack-desc
118
119cd $PKG
120/sbin/makepkg -l y -c n --prepend $TMP/pango-$VERSION-$ARCH-$BUILD.txz
121
Note: See TracBrowser for help on using the repository browser.