source: npl/X/rdesktop/rdesktop.SlackBuild

Last change on this file was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.5 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6#DEP:xorg_lib
7#DEP:xorg_proto
8#DEP:xorg_util
9##DEP:libtiff
10##DEP:libjpeg
11##DEP:libpng
12
13#######Essential package info.
14#Change these if autodetection fails.
15
16#Name of the Syn-3 package that we are going to create
17NAME=`basename $0|sed 's/.SlackBuild//'`
18
19#Archive of the sourcefiles to unpack
20SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
21
22#Version of the sourcefiles
23VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
24
25#Architecture that the created binaries run on.
26#Use noarch for scripts.
27ARCH=`uname -m`
28
29#from this point on, exit on errors:
30set -e
31
32########Build and create the pacakge.
33#Uncomment the stuff that you dont want or need
34
35#Unpack source
36#(uncomment if not needed)
37syn3_unpack $SRC_ARC
38
39#Directory where the sourcefiles are unpacked.
40#(you might have to adjust this if autodetection fails)
41SRC_DIR=`ls -c|head -1`
42
43#apply patches
44#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
45
46pushd $SRC_DIR
47
48#AUTOMAKE: Configure
49#Some usefull stuff you sometimes need to set:
50#export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/"
51#export LD_LIBRARY_PATH=/usr/lib/mysql
52#export VPATH=$LD_LIBRARY_PATH
53#export CFLAGS="-std=c89"
54#export CFLAGS="-fgnu89-inline" #If "multiple definition of `foo'" Also see http://gcc.gnu.org/gcc-4.3/porting_to.html
55MAKE_OPTS=""
56./configure --prefix=/usr --disable-credssp --disable-smartcard || exit 1
57
58#AUTOMAKE: Compile
59make $MAKE_OPTS || exit 1
60
61#AUTOMAKE: Test (optional)
62if grep ^test: Makefile; then
63        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
64        make $MAKE_OPTS test || exit 1
65elif grep ^check: Makefile; then
66        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
67        make $MAKE_OPTS check || exit 1
68fi
69
70#AUTOMAKE: Install
71mkdir -p /tmp/pkg &>/dev/null
72make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install || exit 1
73popd
74
75#strip bins and other stuff
76syn3_strip /tmp/pkg || exit 1
77
78#move development stuff and create seperate development package
79syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
80syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
81
82#make main package
83syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
84
85
86
Note: See TracBrowser for help on using the repository browser.