Last change
on this file was
c5c522c,
checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago
|
initial commit, transferred from cleaned syn3 svn tree
|
-
Property mode set to
100755
|
File size:
584 bytes
|
Line | |
---|
1 | #!/bin/bash |
---|
2 | |
---|
3 | #DEP:libjpeg |
---|
4 | #DEP:xorg_lib |
---|
5 | #DEP:xorg_proto |
---|
6 | #DEP:xorg_util |
---|
7 | |
---|
8 | NAME=tightvnc |
---|
9 | VER=1.3.10 |
---|
10 | CWD=`pwd` |
---|
11 | PKGTMP=/tmp/pkgtmp |
---|
12 | |
---|
13 | mkdir -p $PKGTMP &>/dev/null |
---|
14 | |
---|
15 | tar -xzf $NAME-$VER""_unixsrc.tar.gz || exit 1 |
---|
16 | |
---|
17 | cd vnc_unixsrc || exit 1 |
---|
18 | |
---|
19 | xmkmf || exit 1 |
---|
20 | make World # dont care|| exit 1 |
---|
21 | |
---|
22 | cd Xvnc || exit 1 |
---|
23 | ./configure || exit 1 |
---|
24 | make -j1 || exit 1 |
---|
25 | |
---|
26 | |
---|
27 | cd .. |
---|
28 | mkdir -p $PKGTMP/usr/bin |
---|
29 | mkdir -p $PKGTMP/usr/man |
---|
30 | |
---|
31 | ./vncinstall $PKGTMP/usr/bin $PKGTMP/usr/man || exit 1 |
---|
32 | |
---|
33 | cd "$PKGTMP" || exit 1 |
---|
34 | makepkg -l y -c n $CWD/$NAME.pkg > /dev/null && |
---|
35 | echo $VER > $CWD/$NAME.version && |
---|
36 | arch > $CWD/$NAME.arch |
---|
37 | |
---|
Note: See
TracBrowser
for help on using the repository browser.