source: npl/X/tightvnc/tightvnc.SlackBuild

Last change on this file was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 584 bytes
Line 
1#!/bin/bash
2
3#DEP:libjpeg
4#DEP:xorg_lib
5#DEP:xorg_proto
6#DEP:xorg_util
7
8NAME=tightvnc
9VER=1.3.10
10CWD=`pwd`
11PKGTMP=/tmp/pkgtmp
12
13mkdir -p $PKGTMP &>/dev/null
14
15tar -xzf $NAME-$VER""_unixsrc.tar.gz || exit 1
16
17cd vnc_unixsrc || exit 1
18
19xmkmf || exit 1
20make World # dont care|| exit 1
21
22cd Xvnc || exit 1
23./configure || exit 1
24make -j1 || exit 1
25
26
27cd ..
28mkdir -p $PKGTMP/usr/bin
29mkdir -p $PKGTMP/usr/man
30
31./vncinstall $PKGTMP/usr/bin $PKGTMP/usr/man || exit 1
32
33cd "$PKGTMP" || exit 1
34makepkg -l y -c n $CWD/$NAME.pkg > /dev/null &&
35echo $VER > $CWD/$NAME.version &&
36arch > $CWD/$NAME.arch
37
Note: See TracBrowser for help on using the repository browser.