source: npl/X/xdialog/xdialog.SlackBuild @ 128fde4

gcc484perl-5.22
Last change on this file since 128fde4 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.9 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#Strict build-dependencies.
8#Only use when really neccesary, this will rebuild our package if the dependencie has changed:
9##DEP:linux
10##DEP:linux_src
11
12#Loose build-dependencies.
13#Use this to specify the packages that are required to build our package:
14##NEED:libcairo
15#DEP:glib
16#DEP:gtk+
17#DEP:xorg_lib
18#DEP:xorg_proto
19
20#######Essential package info.
21#Change these if autodetection fails.
22
23#Name of the Syn-3 package that we are going to create
24NAME=`basename $0|sed 's/.SlackBuild//'`
25
26#Archive of the sourcefiles to unpack
27SRC_ARC=`ls *.tar.*`
28
29#Version of the sourcefiles
30VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
31
32#Directory of the sourcefiles to build (after optional unpacking)
33SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
34
35#Architecture that the created binaries run on.
36#Use noarch for scripts.
37ARCH=`arch`
38
39
40########Build and create the pacakge.
41#Uncomment the stuff that you dont want or need
42
43#Unpack source
44#(uncomment if not needed)
45syn3_unpack $SRC_ARC || exit 1
46
47#apply patches
48#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
49
50#build and install sourcefiles
51#(use one of the other syn3_build_* scripts when needed)
52export CONFIGURE_OPTS=""
53export MAKE_OPTS=""
54export NOTEST=1
55syn3_build_automake $SRC_DIR /tmp/pkg || exit 1
56
57#strip bins and other stuff
58syn3_strip /tmp/pkg || exit 1
59
60#move development stuff and create seperate development package
61syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
62syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
63
64#make main package
65syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
66
67
Note: See TracBrowser for help on using the repository browser.