source: npl/X/xkeyboard_config/xkeyboard_config.SlackBuild @ c5c522c

gcc484ntopperl-5.22
Last change on this file since c5c522c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.1 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#NEED:xorg_app
8#NEED:intltool
9#NEED:xorg_proto
10
11#######Essential package info.
12#Change these if autodetection fails.
13
14#Name of the Syn-3 package that we are going to create
15NAME=`basename $0|sed 's/.SlackBuild//'`
16
17#Archive of the sourcefiles to unpack
18SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
19
20#Version of the sourcefiles
21VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
22
23#Architecture that the created binaries run on.
24#Use noarch for scripts.
25ARCH=`uname -m`
26
27#from this point on, exit on errors:
28set -e
29
30########Build and create the pacakge.
31#Uncomment the stuff that you dont want or need
32
33#Unpack source
34#(uncomment if not needed)
35syn3_unpack $SRC_ARC
36
37#Directory where the sourcefiles are unpacked.
38#(you might have to adjust this if autodetection fails)
39SRC_DIR=`ls -c|head -1`
40
41#apply patches
42#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
43
44pushd $SRC_DIR
45
46#AUTOMAKE: Configure
47source /etc/xorg_build.conf || exit 1
48./configure $CONFIGURE_OPTS  || exit 1
49
50#AUTOMAKE: Compile
51make $MAKE_OPTS || exit 1
52
53#AUTOMAKE: Test (optional)
54if grep ^test: Makefile; then
55        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
56        make $MAKE_OPTS test || exit 1
57elif grep ^check: Makefile; then
58        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
59        make $MAKE_OPTS check || exit 1
60fi
61
62#AUTOMAKE: Install
63mkdir -p /tmp/pkg &>/dev/null
64make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install || exit 1
65popd
66
67#strip bins and other stuff
68syn3_strip /tmp/pkg || exit 1
69
70#move development stuff and create seperate development package
71syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
72syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
73
74#make main package
75syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
76
77
78
Note: See TracBrowser for help on using the repository browser.