source: npl/X/xorg/lib/xorg_lib.SlackBuild @ c5c522c

gcc484ntopperl-5.22
Last change on this file since c5c522c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 986 bytes
Line 
1#!/bin/sh
2#
3#
4#DEP:fontconfig
5#DEP:freetype2
6#DEP:expat
7#DEP:xorg_proto
8#DEP:check
9#DEP:libxslt
10#DEP:pthread_stubs
11#DEP:zlib
12#DEP:bzip2
13
14#algemene settings
15source /etc/xorg_build.conf || exit 1
16
17NAME=xorg_lib
18VERSION=7.7
19
20CWD=`pwd`
21PKG=/tmp/pkg
22mkdir $PKG || exit 1
23
24export NOTEST=1
25
26cd mods || exit 1
27#de buildvolgorde is belangrijke, vandaar dat we vanuit een listfile builden.
28for MODNAME in `cat ../mods.list`
29do
30  MOD=`echo $MODNAME-*`
31  MODDIR=$(echo $MOD | sed 's/.tar.bz2//')
32  syn3_unpack $MOD || exit 1
33  syn3_build_automake $MODDIR $PKG || exit 1
34  #the mods depend on eachother, so we need to install them
35  pushd $MODDIR || exit 1
36  make pkgconfigdir=/usr/lib/pkgconfig install || exit 1
37  popd || exit 1
38  rm -rf $MODDIR || exit 1
39done
40
41cd $CWD
42syn3_strip $PKG || exit 1
43
44#make seperate package of development stuff
45syn3_move_dev $PKG /tmp/pkgdev || exit 1
46syn3_makepkg /tmp/pkgdev $NAME""_dev $VERSION `arch` || exit 1
47
48syn3_makepkg $PKG $NAME $VERSION `arch` || exit 1
Note: See TracBrowser for help on using the repository browser.