source: npl/X/xorg/xserver/xorg_xserver.SlackBuild

Last change on this file was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.5 KB
Line 
1#!/bin/sh
2#
3#
4#DEP:freetype2
5#DEP:xorg_proto
6#DEP:xorg_app
7#DEP:xorg_lib
8#DEP:xorg_font
9#DEP:libmesa
10#DEP:libdrm
11#DEP:ncurses
12#DEP:pixman
13#DEP:openssl
14#DEP:bzip2
15#DEP:zlib
16
17#algemene settings
18source /etc/xorg_build.conf || exit 1
19
20NAME=xorg_xserver
21VERSION=1.12.2
22CWD=`pwd`
23
24PKG=/tmp/pkg
25mkdir $PKG || exit 1
26
27
28#zitten nu in xorg_conf!
29#run script
30#mkdir -p $PKG/service/X || exit 1
31#cp run $PKG/service/X/run || exit 1
32#chmod +x $PKG/service/X/run || exit 1
33
34#postinst
35#mkdir -p $PKG/etc/postinst.d
36#cp post.xserver $PKG/etc/postinst.d || exit  1
37#chmod +x $PKG/etc/postinst.d/post.xserver || exit 1
38
39MOD=xorg-server-$VERSION.tar.bz2
40MODDIR=xorg-server-$VERSION
41syn3_unpack $MOD || exit 1
42
43#hack glx om omdat mesa op andere plek staat:
44#(geript van lfs)
45#cd $MODDIR
46#sed -i \
47#    's@-I$(top_builddir)/include@-I$(top_builddir)/GL/mesa/main@8' \
48#    GL/glx/Makefile.in || exit 1
49#sed -i \
50#    's@-I$(top_builddir)/include@-I$(top_builddir)/GL/mesa/glapi@7' \
51#    GL/glx/Makefile.in || exit 1
52cd $CWD
53
54#CONFIGURE_OPTS="$CONFIGURE_OPTS --enable-glx --with-mesa-source=/usr/src/Mesa-*"
55
56#we dont need the fancy glx/dri stuff for just the installer in fbdev-mode :)
57
58CONFIGURE_OPTS="$CONFIGURE_OPTS  --disable-dri --disable-dri2 --disable-glx"
59#NOTEST=1 syn3_build_automake $MODDIR $PKG || exit 1
60syn3_build_automake $MODDIR $PKG || exit 1
61
62syn3_strip $PKG || exit 1
63
64#make seperate package of development stuff
65syn3_move_dev $PKG /tmp/pkgdev || exit 1
66syn3_makepkg /tmp/pkgdev $NAME""_dev $VERSION `arch` || exit 1
67
68syn3_makepkg $PKG $NAME $VERSION `arch` || exit 1
69
Note: See TracBrowser for help on using the repository browser.