source: npl/X/xorg_conf/xorg_conf.SlackBuild

Last change on this file was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 592 bytes
Line 
1#!/bin/bash
2NAME=xorg_conf
3VER=1.0
4CWD=`pwd`
5PKGTMP=/tmp/pkgtmp
6
7mkdir -p $PKGTMP &>/dev/null
8
9mkdir -p $PKGTMP/etc/X11/syn-3 || exit 1
10cp confs/* $PKGTMP/etc/X11/syn-3 || exit 1
11
12#run script
13mkdir -p $PKGTMP/service/X || exit 1
14cp run $PKGTMP/service/X/run || exit 1
15chmod +x $PKGTMP/service/X/run || exit 1
16
17#postinst
18mkdir -p $PKGTMP/etc/postinst.d
19cp post.xorg_conf $PKGTMP/etc/postinst.d || exit  1
20chmod +x $PKGTMP/etc/postinst.d/post.xorg_conf || exit 1
21
22cd "$PKGTMP" || exit 1
23makepkg -l y -c n $CWD/$NAME.pkg > /dev/null &&
24echo $VER > $CWD/$NAME.version &&
25arch > $CWD/$NAME.arch
26
Note: See TracBrowser for help on using the repository browser.