1 | #!/bin/bash |
---|
2 | #Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild |
---|
3 | #Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven. |
---|
4 | #Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden. |
---|
5 | ##################################### Build dependency info: |
---|
6 | #DEP:libtermcap |
---|
7 | #DEP:xorg_proto |
---|
8 | #DEP:xorg_lib |
---|
9 | #DEP:ncurses |
---|
10 | |
---|
11 | #######Essential package info. |
---|
12 | #Change these if autodetection fails. |
---|
13 | |
---|
14 | #Name of the Syn-3 package that we are going to create |
---|
15 | NAME=`basename $0|sed 's/.SlackBuild//'` |
---|
16 | |
---|
17 | #Archive of the sourcefiles to unpack |
---|
18 | SRC_ARC=`ls *.tar.gz` |
---|
19 | |
---|
20 | #Version of the sourcefiles |
---|
21 | VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/.tar.gz//g'` |
---|
22 | |
---|
23 | #Directory of the sourcefiles to build (after optional unpacking) |
---|
24 | SRC_DIR=`echo $SRC_ARC| sed 's/.tar.gz//g'` |
---|
25 | |
---|
26 | #Architecture that the created binaries run on. |
---|
27 | #Use noarch for scripts. |
---|
28 | ARCH=`arch` |
---|
29 | |
---|
30 | |
---|
31 | ########Build and create the pacakge. |
---|
32 | #Uncomment the stuff that you dont want or need |
---|
33 | |
---|
34 | #Unpack source |
---|
35 | #(uncomment if not needed) |
---|
36 | syn3_unpack $SRC_ARC || exit 1 |
---|
37 | |
---|
38 | #apply patches |
---|
39 | #patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1 |
---|
40 | |
---|
41 | #build and install sourcefiles |
---|
42 | #(use one of the other syn3_build_* scripts when needed) |
---|
43 | export CONFIGURE_OPTS="" |
---|
44 | export MAKE_OPTS="-j1" |
---|
45 | #export NOTEST=1 |
---|
46 | syn3_build_automake $SRC_DIR /tmp/pkg || exit 1 |
---|
47 | |
---|
48 | #strip bins and other stuff |
---|
49 | syn3_strip /tmp/pkg || exit 1 |
---|
50 | |
---|
51 | #move development stuff and create seperate development package |
---|
52 | syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1 |
---|
53 | syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1 |
---|
54 | |
---|
55 | #make main package |
---|
56 | syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1 |
---|
57 | |
---|
58 | |
---|