1 | #!/bin/bash |
---|
2 | #Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild |
---|
3 | #Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven. |
---|
4 | #Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden. |
---|
5 | ##################################### Build dependency info: |
---|
6 | |
---|
7 | #NEED:cmake |
---|
8 | #DEP:libaio |
---|
9 | |
---|
10 | #######Essential package info. |
---|
11 | #Change these if autodetection fails. |
---|
12 | |
---|
13 | #Name of the Syn-3 package that we are going to create |
---|
14 | NAME=`basename $0|sed 's/.SlackBuild//'` |
---|
15 | |
---|
16 | #Archive of the sourcefiles to unpack |
---|
17 | SRC_ARC=`ls *.tar.*` |
---|
18 | |
---|
19 | #Version of the sourcefiles |
---|
20 | VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'` |
---|
21 | |
---|
22 | #Directory of the sourcefiles to build (after optional unpacking) |
---|
23 | SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'` |
---|
24 | |
---|
25 | #Architecture that the created binaries run on. |
---|
26 | #Use noarch for scripts. |
---|
27 | ARCH=`arch` |
---|
28 | |
---|
29 | |
---|
30 | ########Build and create the pacakge. |
---|
31 | #Uncomment the stuff that you dont want or need |
---|
32 | |
---|
33 | #Unpack source |
---|
34 | #(uncomment if not needed) |
---|
35 | syn3_unpack $SRC_ARC || exit 1 |
---|
36 | |
---|
37 | #apply patches |
---|
38 | #patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1 |
---|
39 | |
---|
40 | #build and install sourcefiles |
---|
41 | #(use one of the other syn3_build_* scripts when needed) |
---|
42 | #export CONFIGURE_OPTS=" |
---|
43 | # --with-mysqld-user=mysql \ |
---|
44 | # --with-unix-socket-path=/var/run/mysql/mysql.sock \ |
---|
45 | # --localstatedir=/home/system/mysql55 \ |
---|
46 | # --enable-assembler \ |
---|
47 | # --without-debug \ |
---|
48 | # --enable-thread-safe-client \ |
---|
49 | # --without-bench \ |
---|
50 | # --with-plugins=max \ |
---|
51 | # --with-extra-charsets=complex \ |
---|
52 | #" |
---|
53 | |
---|
54 | mkdir $SRC_DIR/bld |
---|
55 | pushd $SRC_DIR/bld || exit 1 |
---|
56 | |
---|
57 | cmake .. \ |
---|
58 | -DBUILD_CONFIG=mysql_release \ |
---|
59 | -DCMAKE_INSTALL_PREFIX=/tmp/pkg/usr \ |
---|
60 | -DINSTALL_DOCREADMEDIR=/tmp \ |
---|
61 | -DINSTALL_DOCDIR=/tmp \ |
---|
62 | -DINSTALL_MYSQLDATADIR=/tmp \ |
---|
63 | -DINSTALL_MYSQLTESTDIR=/tmp \ |
---|
64 | -DINSTALL_SUPPORTFILESDIR=/tmp \ |
---|
65 | -DINSTALL_MYSQLSHAREDIR=share/mysql \ |
---|
66 | -DINSTALL_MANDIR=share/man \ |
---|
67 | -DINSTALL_INFODIR=/tmp \ |
---|
68 | -DINSTALL_SCRIPTDIR=bin \ |
---|
69 | -DINSTALL_LIBDIR=lib/mysql \ |
---|
70 | -DINSTALL_PLUGINDIR=lib/mysql/plugin || exit 1 |
---|
71 | make -j 10 || exit 1 |
---|
72 | make test || exit 1 |
---|
73 | make install/strip || exit 1 |
---|
74 | |
---|
75 | |
---|
76 | popd |
---|
77 | |
---|
78 | #export MAKE_OPTS="-j2" |
---|
79 | #export NOTEST=1 |
---|
80 | #syn3_build_automake $SRC_DIR /tmp/pkg || exit 1 |
---|
81 | |
---|
82 | #service startstop scripts |
---|
83 | PKG=/tmp/pkg |
---|
84 | mkdir -p $PKG/service/mysql |
---|
85 | cp {stop,start,run} $PKG/service/mysql |
---|
86 | chown root:root $PKG/service/mysql/{stop,start,run} |
---|
87 | chmod 755 $PKG/service/mysql/{stop,start,run} || exit 1 |
---|
88 | |
---|
89 | #post installer |
---|
90 | mkdir -p $PKG/etc/postinst.d |
---|
91 | cp post.mysqld $PKG/etc/postinst.d |
---|
92 | |
---|
93 | #config file |
---|
94 | mkdir -p $PKG/etc |
---|
95 | cp my.cnf $PKG/etc/my.cnf.new |
---|
96 | chown root:root $PKG/etc/my.cnf.new |
---|
97 | chmod 644 $PKG/etc/my.cnf.new || exit 1 |
---|
98 | |
---|
99 | #troep |
---|
100 | rm -rf $PKG/usr/mysql-test/ $PKG/usr/sql-bench/ $PKG/tmp $PKG/usr/data |
---|
101 | |
---|
102 | #strip bins and other stuff |
---|
103 | syn3_strip /tmp/pkg || exit 1 |
---|
104 | |
---|
105 | #move development stuff and create seperate development package |
---|
106 | syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1 |
---|
107 | syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1 |
---|
108 | |
---|
109 | #make main package |
---|
110 | syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1 |
---|
111 | |
---|
112 | |
---|