source: npl/commonservers/mysql56/mysql56.SlackBuild @ cd5d2d4

gcc484ntopperl-5.22
Last change on this file since cd5d2d4 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.1 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#NEED:cmake
8#DEP:libaio
9#DEP:ncurses
10
11#######Essential package info.
12#Change these if autodetection fails.
13
14#Name of the Syn-3 package that we are going to create
15NAME=`basename $0|sed 's/.SlackBuild//'`
16
17#Archive of the sourcefiles to unpack
18SRC_ARC=`ls *.tar.*`
19
20#Version of the sourcefiles
21VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
22
23#Directory of the sourcefiles to build (after optional unpacking)
24SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
25
26#Architecture that the created binaries run on.
27#Use noarch for scripts.
28ARCH=`arch`
29
30
31########Build and create the pacakge.
32#Uncomment the stuff that you dont want or need
33
34#Unpack source
35#(uncomment if not needed)
36syn3_unpack $SRC_ARC || exit 1
37
38#apply patches
39#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
40
41mkdir $SRC_DIR/bld
42pushd $SRC_DIR/bld || exit 1
43
44cmake .. \
45        -DBUILD_CONFIG=mysql_release \
46        -DCMAKE_INSTALL_PREFIX=/tmp/pkg/usr \
47        -DINSTALL_DOCREADMEDIR=/tmp \
48        -DINSTALL_DOCDIR=/tmp \
49        -DINSTALL_MYSQLDATADIR=/tmp \
50        -DINSTALL_MYSQLTESTDIR=/tmp \
51        -DINSTALL_INCLUDEDIR=include/mysql \
52        -DINSTALL_SUPPORTFILESDIR=/tmp \
53        -DINSTALL_MYSQLSHAREDIR=share/mysql \
54        -DINSTALL_MANDIR=share/man \
55        -DINSTALL_INFODIR=/tmp \
56        -DINSTALL_SCRIPTDIR=bin \
57        -DINSTALL_LIBDIR=lib \
58        -DINSTALL_PLUGINDIR=lib  || exit 1
59make -j 20 || exit 1
60make test || exit 1
61make install/strip || exit 1
62
63
64popd
65
66
67#troep
68PKG=/tmp/pkg
69rm -rf $PKG/usr/mysql-test/ $PKG/usr/sql-bench/ $PKG/tmp $PKG/usr/data $PKG/etc
70
71#strip bins and other stuff
72syn3_strip /tmp/pkg || exit 1
73
74#move development stuff and create seperate development package
75syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
76syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
77
78#make main package
79syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
80
81
Note: See TracBrowser for help on using the repository browser.