source: npl/commonservers/radius/radius.SlackBuild @ 995241a

gcc484perl-5.22
Last change on this file since 995241a was 995241a, checked in by Edwin Eefting <edwin@datux.nl>, 7 years ago

radius upgrade 2.2.10. seperate config package. remove old radius 1.x files

  • Property mode set to 100755
File size: 965 bytes
RevLine 
[c5c522c]1#!/bin/sh
2#DEP:openldap
3#DEP:openssl
4#DEP:libtermcap
5#DEP:Linux_PAM
6#DEP:libtool
7#DEP:cyrus_sasl
8
9CWD=`pwd`
10TMP=/tmp/tmp
11PKG=/tmp/pkg
12rm -rf $PKG
13mkdir -p $PKG
14
[995241a]15VERSION=2.2.10
[c5c522c]16ARCH=${ARCH:-i486}
17NAME=radius
18
19mkdir -p $TMP
20cd $TMP
21
[995241a]22tar xvf $CWD/freeradius-server-$VERSION.tar.gz || exit 1
[c5c522c]23cd freeradius-server-$VERSION || exit 1
24echo "Uitvoeren van configure..." &&
25./configure --prefix=/usr \
26 --sysconfdir=/home/system/radius \
27 --localstatedir=/var \
28 --sbindir=/usr/sbin \
29 --libdir=/usr/lib \
[995241a]30 --libexecdir=/usr/sbin || exit 1
31make  || exit 1
[c5c522c]32make  R="${PKG}" install || exit 1
33
34
[995241a]35### config stuff is in seperate package
36rm -rf $PKG/home
[c5c522c]37
38
39####
40VER=$VERSION
41cd $CWD
42
43#strip bins and other stuff
44syn3_strip /tmp/pkg || exit 1
45
46#move development stuff and create seperate development package
47syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
48syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
49
50#make main package
51syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
Note: See TracBrowser for help on using the repository browser.