gcc484perl-5.22
Last change
on this file since 995241a was
995241a,
checked in by Edwin Eefting <edwin@datux.nl>, 7 years ago
|
radius upgrade 2.2.10. seperate config package. remove old radius 1.x files
|
-
Property mode set to
100755
|
File size:
965 bytes
|
Rev | Line | |
---|
[c5c522c] | 1 | #!/bin/sh |
---|
| 2 | #DEP:openldap |
---|
| 3 | #DEP:openssl |
---|
| 4 | #DEP:libtermcap |
---|
| 5 | #DEP:Linux_PAM |
---|
| 6 | #DEP:libtool |
---|
| 7 | #DEP:cyrus_sasl |
---|
| 8 | |
---|
| 9 | CWD=`pwd` |
---|
| 10 | TMP=/tmp/tmp |
---|
| 11 | PKG=/tmp/pkg |
---|
| 12 | rm -rf $PKG |
---|
| 13 | mkdir -p $PKG |
---|
| 14 | |
---|
[995241a] | 15 | VERSION=2.2.10 |
---|
[c5c522c] | 16 | ARCH=${ARCH:-i486} |
---|
| 17 | NAME=radius |
---|
| 18 | |
---|
| 19 | mkdir -p $TMP |
---|
| 20 | cd $TMP |
---|
| 21 | |
---|
[995241a] | 22 | tar xvf $CWD/freeradius-server-$VERSION.tar.gz || exit 1 |
---|
[c5c522c] | 23 | cd freeradius-server-$VERSION || exit 1 |
---|
| 24 | echo "Uitvoeren van configure..." && |
---|
| 25 | ./configure --prefix=/usr \ |
---|
| 26 | --sysconfdir=/home/system/radius \ |
---|
| 27 | --localstatedir=/var \ |
---|
| 28 | --sbindir=/usr/sbin \ |
---|
| 29 | --libdir=/usr/lib \ |
---|
[995241a] | 30 | --libexecdir=/usr/sbin || exit 1 |
---|
| 31 | make || exit 1 |
---|
[c5c522c] | 32 | make R="${PKG}" install || exit 1 |
---|
| 33 | |
---|
| 34 | |
---|
[995241a] | 35 | ### config stuff is in seperate package |
---|
| 36 | rm -rf $PKG/home |
---|
[c5c522c] | 37 | |
---|
| 38 | |
---|
| 39 | #### |
---|
| 40 | VER=$VERSION |
---|
| 41 | cd $CWD |
---|
| 42 | |
---|
| 43 | #strip bins and other stuff |
---|
| 44 | syn3_strip /tmp/pkg || exit 1 |
---|
| 45 | |
---|
| 46 | #move development stuff and create seperate development package |
---|
| 47 | syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1 |
---|
| 48 | syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1 |
---|
| 49 | |
---|
| 50 | #make main package |
---|
| 51 | syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1 |
---|
Note: See
TracBrowser
for help on using the repository browser.