source: npl/commonservers/ucspi-tcp/ucspi_tcp.SlackBuild @ c5c522c

gcc484ntopperl-5.22
Last change on this file since c5c522c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.9 KB
Line 
1#!/bin/sh
2#DEP:slackpackage
3
4## Include the slackware-pkg conf file
5if [ -a /etc/slack-package.conf ]; then
6. /etc/slack-package.conf
7  else
8  echo "Sorry you need to have the slack-package.conf file to run these"
9  echo "please install the slackbuilds package from LinuxPackages.net"
10  exit 1
11fi
12
13# Set initial variables:
14NAME=ucspi_tcp
15VERSION=0.88
16TAR=ucspi-tcp-$VERSION
17BUILD=1DatuX
18
19## Location to download the sources
20SRC_LOC="http://cr.yp.to/ucspi-tcp/$TAR.tar.gz"
21
22PKG=$TMP/package-$TAR
23
24## Lets Grab the Source if needed
25if [ -a $CWD/$TAR.tar.gz ]; then
26  echo "Source present not downloading"
27  else
28  $WGET $SRC_LOC || true
29fi
30
31if [ ! -d $TMP ]; then
32  mkdir -p $TMP # location to build the source
33fi
34
35rm -rf $PKG
36mkdir -p $PKG
37
38cd $TMP
39rm -rf $TAR
40tar xzvf $CWD/$TAR.tar.gz
41
42compile() {
43cd $TAR
44patch -p1 < $CWD/ucspi-tcp-0.88.a_record.patch
45patch -p1 < $CWD/ucspi-tcp-0.88.errno.patch
46patch -p1 < $CWD/ucspi-tcp-0.88.nodefaultrbl.patch
47make
48}
49
50prepare() {
51mkdir -p $PKG/usr/bin
52cp who@ $PKG/usr/bin
53cp tcprules $PKG/usr/bin
54cp tcpclient $PKG/usr/bin
55cp mconnect-io $PKG/usr/bin
56cp addcr $PKG/usr/bin
57cp argv0 $PKG/usr/bin
58cp date@ $PKG/usr/bin
59cp delcr $PKG/usr/bin
60cp http@ $PKG/usr/bin
61cp tcprulescheck $PKG/usr/bin
62cp tcpserver $PKG/usr/bin
63cp finger@ $PKG/usr/bin
64cp fixcrio $PKG/usr/bin
65cp rblsmtpd $PKG/usr/bin
66cp tcpcat $PKG/usr/bin
67cp mconnect $PKG/usr/bin
68cp recordio $PKG/usr/bin
69}
70
71description() {
72mkdir -p $PKG/install
73        cat > $PKG/install/slack-desc << END
74      |-----handy-ruler------------------------------------------------------|
75$NAME: $NAME $VERSION
76$NAME:
77$NAME:
78$NAME:
79$NAME:
80$NAME:
81$NAME:
82$NAME:
83$NAME:
84$NAME:
85$NAME:
86END
87}
88
89build() {
90# Build the package:
91cd $PKG
92#makepkg -l y -c n $CWD/$NAME-$VERSION-$ARCH-$BUILD.tgz
93makepkg -l y -c n $CWD/$NAME.pkg > /dev/null &&
94echo $VERSION > $CWD/$NAME.version &&
95arch > $CWD/$NAME.arch
96}
97
98compile
99prepare
100description
101build
Note: See TracBrowser for help on using the repository browser.