source: npl/fileserver/ghostscript/ghostscript.SlackBuild @ c5c522c

gcc484ntopperl-5.22
Last change on this file since c5c522c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.0 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#Strict build-dependencies.
8#Only use when really neccesary, this will rebuild our package if the dependencie has changed:
9##DEP:linux
10##DEP:linux_src
11
12#Loose build-dependencies.
13#Use this to specify the packages that are required to build our package:
14##NEED:libcairo
15##NEED:glib
16##NEED:gtk+
17##NEED:glib2
18##NEED:gtk+2
19##NEED:xorg_lib
20##NEED:xorg_proto
21#DEP:cups
22#DEP:fontconfig
23#DEP:libjpeg
24#DEP:libpng
25#DEP:freetype2
26#DEP:expat
27
28#######Essential package info.
29#Change these if autodetection fails.
30
31#Name of the Syn-3 package that we are going to create
32NAME=`basename $0|sed 's/.SlackBuild//'`
33
34#Archive of the sourcefiles to unpack
35SRC_ARC=`ls *.tar.*`
36
37#Version of the sourcefiles
38VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
39
40#Directory of the sourcefiles to build (after optional unpacking)
41SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
42
43#Architecture that the created binaries run on.
44#Use noarch for scripts.
45ARCH=`arch`
46
47
48########Build and create the pacakge.
49#Uncomment the stuff that you dont want or need
50
51#Unpack source
52#(uncomment if not needed)
53syn3_unpack $SRC_ARC || exit 1
54
55
56#build and install sourcefiles
57#(use one of the other syn3_build_* scripts when needed)
58export CONFIGURE_OPTS="--enable-cups --enable-dynamic --with-drivers=ALL --sysconfdir=/home/system"
59export MAKE_OPTS="-j1"
60#export NOTEST=1
61syn3_build_automake $SRC_DIR /tmp/pkg || exit 1
62
63#strip bins and other stuff
64syn3_strip /tmp/pkg || exit 1
65
66#move development stuff and create seperate development package
67syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
68syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
69
70#make main package
71syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
72
73
Note: See TracBrowser for help on using the repository browser.