source: npl/fileserver/git/git.SlackBuild @ 390e5e0

perl-5.22
Last change on this file since 390e5e0 was 390e5e0, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

https support

  • Property mode set to 100755
File size: 1.6 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#DEP:openssl
8#DEP:zlib
9#DEP:python
10#DEP:curl
11
12#######Essential package info.
13#Change these if autodetection fails.
14
15#Name of the Syn-3 package that we are going to create
16NAME=`basename $0|sed 's/.SlackBuild//'`
17
18#Archive of the sourcefiles to unpack
19SRC_ARC=`ls *.tar.*`
20
21#Version of the sourcefiles
22VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
23
24#Directory of the sourcefiles to build (after optional unpacking)
25SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
26
27#Architecture that the created binaries run on.
28#Use noarch for scripts.
29ARCH=`arch`
30
31
32########Build and create the pacakge.
33#Uncomment the stuff that you dont want or need
34
35#Unpack source
36#(uncomment if not needed)
37syn3_unpack $SRC_ARC || exit 1
38
39#apply patches
40#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
41
42#build and install sourcefiles
43#(use one of the other syn3_build_* scripts when needed)
44export CONFIGURE_OPTS=""
45export MAKE_OPTS=""
46export NOTEST=1
47pushd $SRC_DIR
48make configure || exit 1
49popd
50syn3_build_automake $SRC_DIR /tmp/pkg || exit 1
51
52#strip bins and other stuff
53syn3_strip /tmp/pkg || exit 1
54
55#move development stuff and create seperate development package
56syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
57syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
58
59#make main package
60syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
61
62
Note: See TracBrowser for help on using the repository browser.