source: npl/fileserver/gutenprint/gutenprint.SlackBuild.orig @ 105afb5

Last change on this file since 105afb5 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 4.2 KB
Line 
1#!/bin/sh
2
3# Copyright 2008, 2009, 2010, 2015, 2016  Patrick J. Volkerding, Sebeka, MN, USA
4# All rights reserved.
5#
6# Redistribution and use of this script, with or without modification, is
7# permitted provided that the following conditions are met:
8#
9# 1. Redistributions of this script must retain the above copyright
10#    notice, this list of conditions and the following disclaimer.
11#
12#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
13#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
14#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
15#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
16#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
17#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
18#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
19#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
20#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
21#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22
23
24VERSION=${VERSION:-$(echo gutenprint-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
25BUILD=${BUILD:-2}
26
27# Automatically determine the architecture we're building on:
28if [ -z "$ARCH" ]; then
29  case "$( uname -m )" in
30    i?86) export ARCH=i586 ;;
31    arm*) export ARCH=arm ;;
32    # Unless $ARCH is already set, use uname -m for all other archs:
33       *) export ARCH=$( uname -m ) ;;
34  esac
35fi
36
37NUMJOBS=${NUMJOBS:-" -j7 "}
38
39if [ "$ARCH" = "i586" ]; then
40  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
41  LIBDIRSUFFIX=""
42elif [ "$ARCH" = "s390" ]; then
43  SLKCFLAGS="-O2"
44  LIBDIRSUFFIX=""
45elif [ "$ARCH" = "x86_64" ]; then
46  SLKCFLAGS="-O2 -fPIC"
47  LIBDIRSUFFIX="64"
48else
49  SLKCFLAGS="-O2"
50  LIBDIRSUFFIX=""
51fi
52
53CWD=$(pwd)
54TMP=${TMP:-/tmp}
55PKG=$TMP/package-gutenprint
56rm -rf $PKG
57mkdir -p $TMP $PKG
58
59cd $TMP
60rm -rf gutenprint-${VERSION}
61tar xvf $CWD/gutenprint-${VERSION}.tar.?z* || exit 1
62cd gutenprint-${VERSION}
63chown -R root:root .
64find . \
65  \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
66  -exec chmod 755 {} \; -o \
67  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
68  -exec chmod 644 {} \;
69
70./configure \
71  --prefix=/usr \
72  --libdir=/usr/lib${LIBDIRSUFFIX} \
73  --infodir=/usr/info \
74  --mandir=/usr/man \
75  --with-cups \
76  --enable-escputil \
77  --disable-static \
78  --build=$ARCH-slackware-linux
79
80make $NUMJOBS || make || exit 1
81make install DESTDIR=$PKG || exit 1
82
83find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
84  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
85
86# Compress and if needed symlink the man pages:
87if [ -d $PKG/usr/man ]; then
88  ( cd $PKG/usr/man
89    for manpagedir in $(find . -type d -name "man*") ; do
90      ( cd $manpagedir
91        for eachpage in $( find . -type l -maxdepth 1) ; do
92          ln -s $( readlink $eachpage ).gz $eachpage.gz
93          rm $eachpage
94        done
95        gzip -9 *.?
96      )
97    done
98  )
99fi
100
101mkdir -p $PKG/usr/doc/gutenprint-${VERSION}
102cp -a \
103  ABOUT-NLS AUTHORS COPYING* INSTALL NEWS README* \
104  $PKG/usr/doc/gutenprint-${VERSION}
105  ( cd $PKG/usr/doc/gutenprint-${VERSION}
106    ln -sf /usr/share/gutenprint/samples .
107  )
108mv $PKG/usr/share/gutenprint/doc/* $PKG/usr/doc/gutenprint-${VERSION}
109rmdir $PKG/usr/share/gutenprint/doc
110
111# If there's a ChangeLog, installing at least part of the recent history
112# is useful, but don't let it get totally out of control:
113if [ -r ChangeLog ]; then
114  DOCSDIR=$(echo $PKG/usr/doc/*-$VERSION)
115  cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
116  touch -r ChangeLog $DOCSDIR/ChangeLog
117fi
118
119# Big...  it's in the source if you want it.
120rm -f $PKG/usr/share/gutenprint/samples/profile.jpg
121rm -f $PKG/usr/doc/gutenprint-${VERSION}/*.pdf
122
123# Post-install script to update existing PPD files in /etc:
124mkdir -p $PKG/var/log/setup
125cp -a $CWD/setup.cups-genppdupdate $PKG/var/log/setup
126chown root:root $PKG/var/log/setup/setup.cups-genppdupdate
127chmod 755 $PKG/var/log/setup/setup.cups-genppdupdate
128
129mkdir -p $PKG/install
130zcat $CWD/doinst.sh.gz > $PKG/install/doinst.sh
131cat $CWD/slack-desc > $PKG/install/slack-desc
132
133cd $PKG
134/sbin/makepkg --prepend -l y -c n $TMP/gutenprint-$VERSION-$ARCH-$BUILD.txz
135
Note: See TracBrowser for help on using the repository browser.