source: npl/fileserver/hplip/hplip.SlackBuild @ 225b098

perl-5.22
Last change on this file since 225b098 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.1 KB
Line 
1#!/bin/bash
2#DEP:libjpeg
3#DEP:cups
4#DEP:libusb
5#DEP:python
6
7#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
8#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
9#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
10##################################### Build dependency info:
11
12#Strict build-dependencies.
13#Only use when really neccesary, this will rebuild our package if the dependencie has changed:
14##DEP:linux
15##DEP:linux_src
16
17#Loose build-dependencies.
18#Use this to specify the packages that are required to build our package:
19##NEED:libcairo
20##NEED:glib
21##NEED:gtk+
22##NEED:glib2
23##NEED:gtk+2
24##NEED:xorg_lib
25##NEED:xorg_proto
26
27#######Essential package info.
28#Change these if autodetection fails.
29
30#Name of the Syn-3 package that we are going to create
31NAME=`basename $0|sed 's/.SlackBuild//'`
32
33#Archive of the sourcefiles to unpack
34SRC_ARC=`ls *.tar.*`
35
36#Version of the sourcefiles
37VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
38
39#Directory of the sourcefiles to build (after optional unpacking)
40SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
41
42#Architecture that the created binaries run on.
43#Use noarch for scripts.
44ARCH=`arch`
45
46
47########Build and create the pacakge.
48#Uncomment the stuff that you dont want or need
49
50#Unpack source
51#(uncomment if not needed)
52syn3_unpack $SRC_ARC || exit 1
53
54#apply patches
55#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
56
57#build and install sourcefiles
58#./configure optiones:
59export CONFIGURE_OPTS="--disable-network-build --disable-scan-build"
60#options for all make commands:
61export MAKE_OPTS=""
62#skip testing:
63#export NOTEST=1
64#extra optiones for the make install command, use with INSTALL_BASE for example:
65export INSTALL_OPTS=""
66syn3_build_automake $SRC_DIR /tmp/pkg || exit 1
67
68#strip bins and other stuff
69syn3_strip /tmp/pkg || exit 1
70
71#move development stuff and create seperate development package
72syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
73syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
74
75#make main package
76syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
77
78
Note: See TracBrowser for help on using the repository browser.