source: npl/fileserver/mit-kerberos-app/mit_kerberos_appl.SlackBuild @ 1f5b330

gcc484perl-5.22
Last change on this file since 1f5b330 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.3 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#DEP:mit_kerberos
8
9#######Essential package info.
10#Change these if autodetection fails.
11
12#Name of the Syn-3 package that we are going to create
13NAME=`basename $0|sed 's/.SlackBuild//'`
14
15#Archive of the sourcefiles to unpack
16SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
17
18#Version of the sourcefiles
19VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
20
21#Architecture that the created binaries run on.
22#Use noarch for scripts.
23ARCH=`uname -m`
24
25#from this point on, exit on errors:
26set -e
27
28########Build and create the pacakge.
29#Uncomment the stuff that you dont want or need
30
31#Unpack source
32#(uncomment if not needed)
33syn3_unpack $SRC_ARC
34
35#Directory where the sourcefiles are unpacked.
36#(you might have to adjust this if autodetection fails)
37SRC_DIR=`ls -c|head -1`
38
39#apply patches
40#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
41patch -p0 -d $SRC_DIR < mit-krb5-appl-tinfo.patch || exit 1
42patch -p1 -d $SRC_DIR < mit-krb5-appl-sig_t.patch || exit 1
43
44pushd $SRC_DIR
45
46#AUTOMAKE: Configure
47#Some usefull stuff you sometimes need to set:
48#export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/"
49#export LD_LIBRARY_PATH=/usr/lib/mysql
50#export VPATH=$LD_LIBRARY_PATH
51#export CFLAGS="-std=c89"
52#export CFLAGS="-fgnu89-inline" #If "multiple definition of `foo'" Also see http://gcc.gnu.org/gcc-4.3/porting_to.html
53#export CPPFLAGS="-fno-strict-overflow -fno-strict-aliasing"
54MAKE_OPTS=""
55./configure --prefix=/usr  || exit 1
56
57#AUTOMAKE: Compile
58make $MAKE_OPTS || exit 1
59
60
61#AUTOMAKE: Install
62mkdir -p /tmp/pkg &>/dev/null
63make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install || exit 1
64popd
65
66#strip bins and other stuff
67syn3_strip /tmp/pkg || exit 1
68
69#move development stuff and create seperate development package
70syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
71syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
72
73#make main package
74syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
75
76
77
Note: See TracBrowser for help on using the repository browser.