source: npl/fileserver/mit-kerberos/mit_kerberos.SlackBuild

Last change on this file was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.9 KB
Line 
1#!/bin/bash
2#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
3#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
4##################################### Build dependency info:
5#DEP:openldap
6#DEP:libtermcap
7#DEP:openssl
8
9#######Essential package info.
10#Change these if autodetection fails.
11
12#Name of the Syn-3 package that we are going to create
13NAME=`basename $0|sed 's/.SlackBuild//'`
14
15#Archive of the sourcefiles to unpack
16SRC_ARC=`ls *.tar.gz`
17
18#Version of the sourcefiles
19VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
20
21#Directory of the sourcefiles to build (after optional unpacking)
22SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
23
24#Architecture that the created binaries run on.
25#Use noarch for scripts.
26ARCH=`arch`
27
28
29########Build and create the pacakge.
30#Uncomment the stuff that you dont want or need
31
32#Unpack source
33#(uncomment if not needed)
34syn3_unpack $SRC_ARC || exit 1
35
36#apply patches
37#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
38
39#build and install sourcefiles
40#./configure optiones:
41export CONFIGURE_OPTS="--with-ldap --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/home/system/mit_kerberos --localstatedir=/var --enable-dns-for-realm --without-krb4 --without-system-verto"
42#options for all make commands:
43export CFLAGS="-DHAVE_SPNEGO" # http://en.wikipedia.org/wiki/SPNEGO
44export MAKE_OPTS=""
45#skip testing:
46export NOTEST=1
47#extra optiones for the make install command, use with INSTALL_BASE for example:
48export INSTALL_OPTS=""
49syn3_build_automake $SRC_DIR/src /tmp/pkg || exit 1
50
51#strip bins and other stuff
52syn3_strip /tmp/pkg || exit 1
53
54#create missching dirs
55mkdir -p /tmp/pkg/home/system/mit_kerberos
56
57#move development stuff and create seperate development package
58syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
59syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
60
61#make main package
62syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
63
64
Note: See TracBrowser for help on using the repository browser.