source: npl/fileserver/rsync/rsync.SlackBuild @ 67ac101

Last change on this file since 67ac101 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.8 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6#DEP:popt
7#DEP:acl
8
9#Strict build-dependencies
10#Our package will be automaticly rebuilded if there is a major change in a DEP package.
11#(this is recommended for most dependencys)
12##DEP:linux
13##DEP:linux_src
14##DEP:openldap
15
16#Loose build-dependencies
17#The package will be installed in the buildroot during buidling, but no automatic rebuild will occur.
18#(not recommended)
19##NEED:doxygen
20
21#######Essential package info.
22#Change these if autodetection fails.
23
24#Name of the Syn-3 package that we are going to create
25NAME=`basename $0|sed 's/.SlackBuild//'`
26
27#Archive of the sourcefiles to unpack
28SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
29
30#Version of the sourcefiles
31VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
32
33#Architecture that the created binaries run on.
34#Use noarch for scripts.
35ARCH=`uname -m`
36
37#from this point on, exit on errors:
38set -e
39
40########Build and create the pacakge.
41#Uncomment the stuff that you dont want or need
42
43#Unpack source
44#(uncomment if not needed)
45syn3_unpack $SRC_ARC
46
47#Directory where the sourcefiles are unpacked.
48#(you might have to adjust this if autodetection fails)
49SRC_DIR=`ls -c|head -1`
50
51#apply patches
52#patch -p1 -d $SRC_DIR < rsync_3.0.9-4.diff || exit 1
53patch -p1 -d $SRC_DIR < progress-hack.patch || exit 1
54
55pushd $SRC_DIR
56
57#AUTOMAKE: Configure
58#Some usefull stuff you sometimes need to set:
59#export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/"
60#export LD_LIBRARY_PATH=/usr/lib/mysql
61#export VPATH=$LD_LIBRARY_PATH
62MAKE_OPTS=""
63#export CFLAGS="-std=c89"
64export CFLAGS="-fgnu89-inline" #If "multiple definition of `foo'"
65./configure --prefix=/usr  || exit 1
66
67#AUTOMAKE: Compile
68make $MAKE_OPTS || exit 1
69
70#AUTOMAKE: Test (optional)
71if grep ^test: Makefile; then
72        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
73        make $MAKE_OPTS test || exit 1
74elif grep ^check: Makefile; then
75        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
76        make $MAKE_OPTS check || exit 1
77fi
78
79#AUTOMAKE: Install
80mkdir -p /tmp/pkg &>/dev/null
81make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install || exit 1
82popd
83
84#strip bins and other stuff
85syn3_strip /tmp/pkg || exit 1
86
87#move development stuff and create seperate development package
88syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
89syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
90
91#make main package
92syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
93
94
95
Note: See TracBrowser for help on using the repository browser.