[c5c522c] | 1 | #!/bin/bash |
---|
| 2 | #Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild |
---|
| 3 | #Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven. |
---|
| 4 | #Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden. |
---|
| 5 | ##################################### Build dependency info: |
---|
| 6 | #DEP:libpcre |
---|
| 7 | #Strict build-dependencies |
---|
| 8 | #Our package will be automaticly rebuilded if there is a major change in a DEP package. |
---|
| 9 | #(this is recommended for most dependencys) |
---|
| 10 | ##DEP:linux |
---|
| 11 | ##DEP:linux_src |
---|
| 12 | ##DEP:openldap |
---|
| 13 | |
---|
| 14 | #Loose build-dependencies |
---|
| 15 | #The package will be installed in the buildroot during buidling, but no automatic rebuild will occur. |
---|
| 16 | #(not recommended) |
---|
| 17 | ##NEED:doxygen |
---|
| 18 | |
---|
| 19 | #######Essential package info. |
---|
| 20 | #Change these if autodetection fails. |
---|
| 21 | |
---|
| 22 | #Name of the Syn-3 package that we are going to create |
---|
| 23 | NAME=`basename $0|sed 's/.SlackBuild//'` |
---|
| 24 | |
---|
| 25 | #Archive of the sourcefiles to unpack |
---|
| 26 | SRC_ARC=`ls *.tar.* *.zip 2>/dev/null` |
---|
| 27 | |
---|
| 28 | #Version of the sourcefiles |
---|
| 29 | VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'` |
---|
| 30 | |
---|
| 31 | #Architecture that the created binaries run on. |
---|
| 32 | #Use noarch for scripts. |
---|
| 33 | ARCH=`uname -m` |
---|
| 34 | |
---|
| 35 | #from this point on, exit on errors: |
---|
| 36 | set -e |
---|
| 37 | |
---|
| 38 | ########Build and create the pacakge. |
---|
| 39 | #Uncomment the stuff that you dont want or need |
---|
| 40 | |
---|
| 41 | #Unpack source |
---|
| 42 | #(uncomment if not needed) |
---|
| 43 | syn3_unpack $SRC_ARC |
---|
| 44 | |
---|
| 45 | #Directory where the sourcefiles are unpacked. |
---|
| 46 | #(you might have to adjust this if autodetection fails) |
---|
| 47 | SRC_DIR=`ls -c|head -1` |
---|
| 48 | |
---|
| 49 | #apply patches |
---|
| 50 | #patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1 |
---|
| 51 | |
---|
| 52 | pushd $SRC_DIR |
---|
| 53 | |
---|
| 54 | #AUTOMAKE: Configure |
---|
| 55 | #Some usefull stuff you sometimes need to set: |
---|
| 56 | #export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/" |
---|
| 57 | #export LD_LIBRARY_PATH=/usr/lib/mysql |
---|
| 58 | #export VPATH=$LD_LIBRARY_PATH |
---|
| 59 | MAKE_OPTS="" |
---|
| 60 | ./configure --prefix=/usr \ |
---|
| 61 | --libdir=/usr/lib \ |
---|
| 62 | --localstatedir=/var \ |
---|
| 63 | --sysconfdir=/home/system \ |
---|
| 64 | --mandir=/usr/man \ |
---|
| 65 | --docdir=/usr/doc/dansguardian-$VER \ |
---|
| 66 | --enable-pcre \ |
---|
| 67 | --enable-clamd \ |
---|
| 68 | --enable-commandline \ |
---|
| 69 | --enable-email \ |
---|
| 70 | --with-proxyuser=nobody \ |
---|
| 71 | --with-proxygroup=nogroup \ |
---|
| 72 | --program-prefix="" \ |
---|
| 73 | --program-suffix="" \ |
---|
| 74 | --build=$ARCH-slackware-linux |
---|
| 75 | |
---|
| 76 | #AUTOMAKE: Compile |
---|
| 77 | make $MAKE_OPTS || exit 1 |
---|
| 78 | |
---|
| 79 | #AUTOMAKE: Test (optional) |
---|
| 80 | if grep ^test: Makefile; then |
---|
| 81 | make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1 |
---|
| 82 | make $MAKE_OPTS test || exit 1 |
---|
| 83 | elif grep ^check: Makefile; then |
---|
| 84 | make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1 |
---|
| 85 | make $MAKE_OPTS check || exit 1 |
---|
| 86 | fi |
---|
| 87 | |
---|
| 88 | #AUTOMAKE: Install |
---|
| 89 | mkdir -p /tmp/pkg &>/dev/null |
---|
| 90 | make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install || exit 1 |
---|
| 91 | popd |
---|
| 92 | |
---|
| 93 | #strip bins and other stuff |
---|
| 94 | syn3_strip /tmp/pkg || exit 1 |
---|
| 95 | mkdir -p /tmp/pkg/service/dansguardian |
---|
| 96 | |
---|
| 97 | #run script |
---|
| 98 | cp run /tmp/pkg/service/dansguardian |
---|
| 99 | chmod 755 /tmp/pkg/service/dansguardian/run |
---|
| 100 | |
---|
| 101 | # add syn3 custom configration files |
---|
| 102 | cp *.conf /tmp/pkg/home/system/dansguardian |
---|
| 103 | cp template.html /tmp/pkg/usr/share/dansguardian/languages/ukenglish |
---|
| 104 | |
---|
| 105 | # make all configfiles end on .new |
---|
| 106 | for cf in $(find /tmp/pkg/home/system/dansguardian -name *.conf) ; do |
---|
| 107 | mv $cf{,.new} |
---|
| 108 | done |
---|
| 109 | for lf in $(find /tmp/pkg/home/system/dansguardian -name *list) ; do |
---|
| 110 | mv $lf{,.new} |
---|
| 111 | done |
---|
| 112 | |
---|
| 113 | chown nobody /tmp/pkg/var/log/dansguardian |
---|
| 114 | |
---|
| 115 | #move development stuff and create seperate development package |
---|
| 116 | syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1 |
---|
| 117 | syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1 |
---|
| 118 | |
---|
| 119 | #make main package |
---|
| 120 | syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1 |
---|
| 121 | |
---|
| 122 | |
---|
| 123 | |
---|