source: npl/internetserver/idnkit/idnkit.SlackBuild.orig @ c5d681f

perl-5.22
Last change on this file since c5d681f was ebc5ae5, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

upgraded dhcpd to 4.3.6 for better ipv6 support

  • Property mode set to 100755
File size: 3.9 KB
Line 
1#!/bin/sh
2
3# Copyright 2011  Patrick J. Volkerding, Sebeka, MN, USA
4# All rights reserved.
5#
6# Redistribution and use of this script, with or without modification, is
7# permitted provided that the following conditions are met:
8#
9# 1. Redistributions of this script must retain the above copyright
10#    notice, this list of conditions and the following disclaimer.
11#
12#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
13#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
14#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
15#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
16#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
17#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
18#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
19#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
20#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
21#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22
23
24PKGNAM=idnkit
25VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 2 -d - | rev)}
26BUILD=${BUILD:-1}
27
28# Automatically determine the architecture we're building on:
29if [ -z "$ARCH" ]; then
30  case "$( uname -m )" in
31    i?86) export ARCH=i486 ;;
32    arm*) export ARCH=arm ;;
33    # Unless $ARCH is already set, use uname -m for all other archs:
34       *) export ARCH=$( uname -m ) ;;
35  esac
36fi
37
38NUMJOBS=${NUMJOBS:-" -j7 "}
39
40CWD=$(pwd)
41TMP=${TMP:-/tmp}
42PKG=$TMP/package-${PKGNAM}
43rm -rf $PKG
44mkdir -p $TMP $PKG
45
46if [ "$ARCH" = "i486" ]; then
47  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
48  LIBDIRSUFFIX=""
49elif [ "$ARCH" = "s390" ]; then
50  SLKCFLAGS="-O2"
51  LIBDIRSUFFIX=""
52elif [ "$ARCH" = "x86_64" ]; then
53  SLKCFLAGS="-O2 -fPIC"
54  LIBDIRSUFFIX="64"
55fi
56
57cd $TMP
58rm -rf ${PKGNAM}-${VERSION}
59tar xvf $CWD/${PKGNAM}-$VERSION-src.tar.?z* || exit 1
60cd ${PKGNAM}-$VERSION-src || exit 1
61
62# Make sure ownerships and permissions are sane:
63chown -R root:root .
64find . \
65 \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
66 -exec chmod 755 {} \; -o \
67 \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
68 -exec chmod 644 {} \;
69
70# Configure:
71CFLAGS="$SLKCFLAGS" \
72./configure \
73  --prefix=/usr \
74  --libdir=/usr/lib${LIBDIRSUFFIX} \
75  --sysconfdir=/etc \
76  --localstatedir=/var \
77  --mandir=/usr/man \
78  --enable-shared \
79  --disable-static \
80  --build=$ARCH-slackware-linux || exit 1
81
82# Build and install:
83make $NUMJOBS || make || exit 1
84make install DESTDIR=$PKG || exit 1
85
86# Fix library perms:
87chmod 755 $PKG/usr/lib${LIBDIRSUFFIX}/*
88
89# Strip binaries:
90find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
91  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
92
93# Since idnkit appears to work here without configuration files installed,
94# we will only install these as *.sample:
95rm -f $PKG/etc/*.conf
96
97# Compress and link manpages, if any:
98if [ -d $PKG/usr/man ]; then
99  ( cd $PKG/usr/man
100    for manpagedir in $(find . -type d -name "man*") ; do
101      ( cd $manpagedir
102        for eachpage in $( find . -type l -maxdepth 1) ; do
103          ln -s $( readlink $eachpage ).gz $eachpage.gz
104          rm $eachpage
105        done
106        gzip -9 *.* 2> /dev/null
107      )
108    done
109  )
110fi
111
112# Add a documentation directory:
113mkdir -p $PKG/usr/doc/${PKGNAM}-$VERSION
114cp -a \
115  INSTALL* LICENSE* NEWS README* \
116  $PKG/usr/doc/${PKGNAM}-$VERSION
117
118# If there's a ChangeLog, installing at least part of the recent history
119# is useful, but don't let it get totally out of control:
120if [ -r ChangeLog ]; then
121  DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
122  cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
123  touch -r ChangeLog $DOCSDIR/ChangeLog
124fi
125
126mkdir -p $PKG/install
127cat $CWD/slack-desc > $PKG/install/slack-desc
128
129cd $PKG
130/sbin/makepkg -l y -c n $TMP/${PKGNAM}-$(echo $VERSION | tr - _)-$ARCH-$BUILD.txz
131
Note: See TracBrowser for help on using the repository browser.