source: npl/internetserver/iptraf_ng/iptraf-ng.SlackBuild.orig @ 5a444e8

Last change on this file since 5a444e8 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 4.0 KB
Line 
1#!/bin/sh
2
3# Copyright 2008, 2009, 2010, 2011, 2013  Patrick J. Volkerding, Sebeka, MN, USA
4# All rights reserved.
5#
6# Redistribution and use of this script, with or without modification, is
7# permitted provided that the following conditions are met:
8#
9# 1. Redistributions of this script must retain the above copyright
10#    notice, this list of conditions and the following disclaimer.
11#
12#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
13#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
14#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
15#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
16#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
17#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
18#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
19#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
20#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
21#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22
23
24PKGNAM=iptraf-ng
25VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
26BUILD=${BUILD:-1}
27
28# Automatically determine the architecture we're building on:
29if [ -z "$ARCH" ]; then
30  case "$( uname -m )" in
31    i?86) export ARCH=i486 ;;
32    arm*) export ARCH=arm ;;
33    # Unless $ARCH is already set, use uname -m for all other archs:
34       *) export ARCH=$( uname -m ) ;;
35  esac
36fi
37
38NUMJOBS=${NUMJOBS:-" -j7 "}
39
40if [ "$ARCH" = "i486" ]; then
41  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
42  LIBDIRSUFFIX=""
43elif [ "$ARCH" = "s390" ]; then
44  SLKCFLAGS="-O2"
45  LIBDIRSUFFIX=""
46elif [ "$ARCH" = "x86_64" ]; then
47  SLKCFLAGS="-O2 -fPIC"
48  LIBDIRSUFFIX="64"
49else
50  SLKCFLAGS="-O2"
51  LIBDIRSUFFIX=""
52fi
53
54CWD=$(pwd)
55TMP=${TMP:-/tmp}
56PKG=$TMP/package-$PKGNAM
57
58cd $TMP
59rm -rf $PKG
60rm -rf $PKGNAM-$VERSION
61tar xvf $CWD/$PKGNAM-$VERSION.tar.?z* || exit 1
62cd $PKGNAM-$VERSION
63
64chown -R root:root .
65find . \
66  \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
67  -exec chmod 755 {} \; -o \
68  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
69  -exec chmod 644 {} \;
70
71# Configure:
72CFLAGS="$SLKCFLAGS" \
73./configure \
74  --prefix=/usr \
75  --sbindir=/usr/sbin \
76  --sysconfdir=/etc \
77  --libdir=/usr/lib${LIBDIRSUFFIX} \
78  --mandir=/usr/man \
79  --infodir=/usr/info \
80  --disable-static \
81  --build=$ARCH-slackware-linux
82
83make $NUMJOBS || make || exit 1
84make install DESTDIR=$PKG || exit 1
85
86# Make symlinks to the old names:
87( cd $PKG/usr/sbin
88  ln -sf iptraf-ng iptraf
89  ln -sf rvnamed-ng rvnamed
90)
91( cd $PKG/usr/man/man8
92  ln -sf iptraf-ng.8 iptraf.8
93  ln -sf rvnamed-ng.8 rvnamed.8
94)
95
96find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
97  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
98
99mkdir -p $PKG/var/lib/iptraf-ng
100mkdir -p $PKG/var/run/iptraf-ng
101mkdir -p $PKG/var/log/iptraf-ng
102
103mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
104cp -a \
105  Documentation \
106  FAQ INSTALL LICENSE README* RELEASE-NOTES \
107  $PKG/usr/doc/$PKGNAM-$VERSION
108
109# If there's a CHANGES file, installing at least part of the recent history
110# is useful, but don't let it get totally out of control:
111if [ -r CHANGES ]; then
112  DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
113  cat CHANGES | head -n 1000 > $DOCSDIR/CHANGES
114  touch -r CHANGES $DOCSDIR/CHANGES
115fi
116
117# crud removal
118( cd $PKG/usr/doc/$PKGNAM-$VERSION/Documentation
119  rm -rf manual.aux manual.dvi *.log manual.rtf manual.sgml manual.template* .xvpics .log
120)
121
122# Compress and if needed symlink the man pages:
123if [ -d $PKG/usr/man ]; then
124  ( cd $PKG/usr/man
125    for manpagedir in $(find . -type d -name "man*") ; do
126      ( cd $manpagedir
127        for eachpage in $( find . -type l -maxdepth 1) ; do
128          ln -s $( readlink $eachpage ).gz $eachpage.gz
129          rm $eachpage
130        done
131        gzip -9 *.?
132      )
133    done
134  )
135fi
136
137mkdir -p $PKG/install
138cat $CWD/slack-desc > $PKG/install/slack-desc
139
140cd $PKG
141/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz
142
Note: See TracBrowser for help on using the repository browser.