source: npl/internetserver/ipv6calc/ipv6calc.SlackBuild @ 2154c77

Last change on this file since 2154c77 was 2154c77, checked in by Edwin Eefting <edwin@datux.nl>, 3 years ago

various updates

  • Property mode set to 100755
File size: 1.8 KB
RevLine 
[2154c77]1#!/bin/bash
2
3##NEED:...
4
5#######Essential package info.
6#Change these if autodetection fails.
7
8#Name of the Syn-3 package that we are going to create
9NAME=`basename $0|sed 's/.SlackBuild//'`
10
11#Archive of the sourcefiles to unpack
12SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
13
14#Version of the sourcefiles
15VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
16
17#Architecture that the created binaries run on.
18#Use noarch for scripts.
19ARCH=`uname -m`
20
21#from this point on, exit on errors:
22set -e
23
24########Build and create the pacakge.
25#Uncomment the stuff that you dont want or need
26
27#Unpack source
28#(uncomment if not needed)
29syn3_unpack $SRC_ARC
30
31#Directory where the sourcefiles are unpacked.
32#(you might have to adjust this if autodetection fails)
33SRC_DIR=`ls -c|head -1`
34
35#apply patches
36#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
37
38pushd $SRC_DIR
39
40#AUTOMAKE: Configure
41#Some usefull stuff you sometimes need to set:
42#export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/"
43#export LD_LIBRARY_PATH=/usr/lib/mysql
44#export VPATH=$LD_LIBRARY_PATH
45#export CFLAGS="-std=c89"
46#export CFLAGS="-fgnu89-inline" #If "multiple definition of `foo'" Also see http://gcc.gnu.org/gcc-4.3/porting_to.html
47MAKE_OPTS=""
48
49./configure --prefix=/usr  || exit 1
50sed "s@./ipv6calcweb.cgi@@g" -i ipv6calcweb/Makefile
51
52#AUTOMAKE: Compile
53make $MAKE_OPTS || exit 1
54
55
56#AUTOMAKE: Install
57mkdir -p /tmp/pkg &>/dev/null
58make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install || exit 1
59popd
60
61#strip bins and other stuff
62syn3_strip /tmp/pkg || exit 1
63
64#move development stuff and create seperate development package
65syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
66syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
67
68#make main package
69syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
70
71
72
Note: See TracBrowser for help on using the repository browser.