source: npl/internetserver/libpcap/libpcap.SlackBuild.orig @ 2758a4b

perl-5.22
Last change on this file since 2758a4b was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 4.0 KB
Line 
1#!/bin/sh
2
3# Copyright 2008, 2009, 2010, 2012  Patrick J. Volkerding, Sebeka, MN, USA
4# All rights reserved.
5#
6# Redistribution and use of this script, with or without modification, is
7# permitted provided that the following conditions are met:
8#
9# 1. Redistributions of this script must retain the above copyright
10#    notice, this list of conditions and the following disclaimer.
11#
12#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
13#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
14#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
15#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
16#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
17#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
18#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
19#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
20#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
21#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22
23PKGNAM=libpcap
24VERSION=${VERSION:-$(echo $PKGNAM-*.tar.gz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
25BUILD=${BUILD:-1}
26
27# Automatically determine the architecture we're building on:
28if [ -z "$ARCH" ]; then
29  case "$( uname -m )" in
30    i?86) export ARCH=i586 ;;
31    arm*) export ARCH=arm ;;
32    # Unless $ARCH is already set, use uname -m for all other archs:
33       *) export ARCH=$( uname -m ) ;;
34  esac
35fi
36
37NUMJOBS=${NUMJOBS:-" -j7 "}
38
39if [ "$ARCH" = "x86_64" ]; then
40  LIBDIRSUFFIX="64"
41else
42  LIBDIRSUFFIX=""
43fi
44
45CWD=$(pwd)
46TMP=${TMP:-/tmp}
47PKG=$TMP/package-libpcap
48
49rm -rf $PKG
50mkdir -p $TMP $PKG
51
52cd $TMP
53rm -rf libpcap-$VERSION
54tar xvf $CWD/libpcap-$VERSION.tar.gz || exit 1
55cd libpcap-$VERSION || exit 1
56
57find . -type d -name CVS -depth -exec rm -rf {} \;
58chown -R root:root .
59find . \
60  \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
61  -exec chmod 755 {} \; -o \
62  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
63  -exec chmod 644 {} \;
64
65CFLAGS="$(getconf LFS_CFLAGS)" \
66./configure \
67  --prefix=/usr \
68  --libdir=/usr/lib${LIBDIRSUFFIX} \
69  --mandir=/usr/man \
70  --docdir=/usr/doc/libpcap-$VERSION \
71  --enable-ipv6 \
72  --build=$ARCH-slackware-linux
73
74make $NUMJOBS || make || exit 1
75make shared $NUMJOBS || make || exit 1
76
77mkdir -p $PKG/usr/bin  # otherwise it errors out on install
78make install DESTDIR=$PKG || exit 1
79
80strip --strip-debug libpcap.so.1.?.?
81
82mkdir -p $PKG/usr/doc/libpcap-$VERSION
83cp -a \
84  CHANGES CREDITS INSTALL.txt LICENSE README* TODO VERSION \
85  $PKG/usr/doc/libpcap-$VERSION
86
87find $PKG | xargs file | grep -e "executable" -e "shared object" \
88  | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
89
90# Use symbolic links in the man pages:
91( cd $PKG/usr/man/man3
92  ln -sf pcap_datalink_val_to_name.3pcap pcap_datalink_val_to_description.3pcap
93  ln -sf pcap_dump_open.3pcap pcap_dump_fopen.3pcap
94  ln -sf pcap_geterr.3pcap pcap_perror.3pcap
95  ln -sf pcap_inject.3pcap pcap_sendpacket.3pcap
96  ln -sf pcap_loop.3pcap pcap_dispatch.3pcap
97  ln -sf pcap_major_version.3pcap pcap_minor_version.3pcap
98  ln -sf pcap_next_ex.3pcap pcap_next.3pcap
99  ln -sf pcap_open_offline.3pcap pcap_fopen_offline.3pcap
100  ln -sf pcap_setnonblock.3pcap pcap_getnonblock.3pcap
101  ln -sf pcap_findalldevs.3pcap pcap_freealldevs.3pcap
102  #ln -sf pcap_free_tstamp_types.3pcap pcap_list_tstamp_types.3pcap
103  #ln -sf pcap_free_datalinks.3pcap pcap_list_datalinks.3pcap
104)
105
106# Compress and if needed symlink the man pages:
107if [ -d $PKG/usr/man ]; then
108  ( cd $PKG/usr/man
109    for manpagedir in $(find . -type d -name "man*") ; do
110      ( cd $manpagedir
111        for eachpage in $( find . -type l -maxdepth 1) ; do
112          ln -s $( readlink $eachpage ).gz $eachpage.gz
113          rm $eachpage
114        done
115        gzip -9 *.? || true
116        gzip -9 *.?pcap || true
117      )
118    done
119  )
120fi
121
122mkdir -p $PKG/install
123cat $CWD/slack-desc > $PKG/install/slack-desc
124
125# Build the package:
126cd $PKG
127/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz
128
Note: See TracBrowser for help on using the repository browser.