source: npl/internetserver/memcached/memcached.SlackBuild @ 3b59591

Last change on this file since 3b59591 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.7 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#Strict build-dependencies
8#Our package will be automaticly rebuilded if there is a major change in a DEP package.
9#(this is recommended for most dependencys)
10##DEP:linux
11##DEP:linux_src
12##DEP:openldap
13
14#Loose build-dependencies
15#The package will be installed in the buildroot during buidling, but no automatic rebuild will occur.
16#(not recommended)
17##NEED:doxygen
18
19#DEP:libevent
20
21
22#######Essential package info.
23#Change these if autodetection fails.
24
25#Name of the Syn-3 package that we are going to create
26NAME=`basename $0|sed 's/.SlackBuild//'`
27
28#Archive of the sourcefiles to unpack
29SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
30
31#Version of the sourcefiles
32VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
33
34#Architecture that the created binaries run on.
35#Use noarch for scripts.
36ARCH=`uname -m`
37
38#from this point on, exit on errors:
39set -e
40
41########Build and create the pacakge.
42#Uncomment the stuff that you dont want or need
43
44#Unpack source
45#(uncomment if not needed)
46syn3_unpack $SRC_ARC
47
48#Directory where the sourcefiles are unpacked.
49#(you might have to adjust this if autodetection fails)
50SRC_DIR=`ls -c|head -1`
51
52#apply patches
53#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
54
55pushd $SRC_DIR
56
57#AUTOMAKE: Configure
58#Some usefull stuff you sometimes need to set:
59#export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/"
60#export LD_LIBRARY_PATH=/usr/lib/mysql
61#export VPATH=$LD_LIBRARY_PATH
62#export CFLAGS="-std=c89"
63export CFLAGS="-fgnu89-inline" #If "multiple definition of `foo'" Also see http://gcc.gnu.org/gcc-4.3/porting_to.html
64MAKE_OPTS=""
65./configure --prefix=/usr  || exit 1
66
67#AUTOMAKE: Compile
68make $MAKE_OPTS || exit 1
69
70#AUTOMAKE: Test (optional)
71if grep ^test: Makefile; then
72        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
73        make $MAKE_OPTS test || exit 1
74elif grep ^check: Makefile; then
75        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
76        make $MAKE_OPTS check || exit 1
77fi
78
79#AUTOMAKE: Install
80mkdir -p /tmp/pkg &>/dev/null
81make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install || exit 1
82popd
83
84#strip bins and other stuff
85syn3_strip /tmp/pkg || exit 1
86
87#move development stuff and create seperate development package
88syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
89syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
90
91#make main package
92syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
93
94
95
Note: See TracBrowser for help on using the repository browser.