source: npl/internetserver/mod_wsgi/mod_wsgi.SlackBuild @ c5c522c

gcc484ntopperl-5.22
Last change on this file since c5c522c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.1 KB
Line 
1#!/bin/bash
2#DEP:apache2
3#DEP:apr
4#DEP:apr_util
5#DEP:python
6
7#######Essential package info.
8#Change these if autodetection fails.
9
10#Name of the Syn-3 package that we are going to create
11NAME=`basename $0|sed 's/.SlackBuild//'`
12
13#Archive of the sourcefiles to unpack
14SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
15
16#Version of the sourcefiles
17VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
18
19#Architecture that the created binaries run on.
20#Use noarch for scripts.
21ARCH=`uname -m`
22
23#from this point on, exit on errors:
24set -e
25
26########Build and create the pacakge.
27#Uncomment the stuff that you dont want or need
28
29#Unpack source
30#(uncomment if not needed)
31syn3_unpack $SRC_ARC
32
33#Directory where the sourcefiles are unpacked.
34#(you might have to adjust this if autodetection fails)
35SRC_DIR=`ls -c|head -1`
36
37#apply patches
38#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
39
40pushd $SRC_DIR
41
42#AUTOMAKE: Configure
43#Some usefull stuff you sometimes need to set:
44#export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/"
45#export LD_LIBRARY_PATH=/usr/lib/mysql
46#export VPATH=$LD_LIBRARY_PATH
47#export CFLAGS="-std=c89"
48#export CFLAGS="-fgnu89-inline" #If "multiple definition of `foo'" Also see http://gcc.gnu.org/gcc-4.3/porting_to.html
49MAKE_OPTS=""
50./configure --prefix=/usr  || exit 1
51
52#AUTOMAKE: Compile
53make $MAKE_OPTS || exit 1
54
55#AUTOMAKE: Test (optional)
56if grep ^test: Makefile; then
57        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
58        make $MAKE_OPTS test || exit 1
59elif grep ^check: Makefile; then
60        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
61        make $MAKE_OPTS check || exit 1
62fi
63
64#AUTOMAKE: Install
65mkdir -p /tmp/pkg &>/dev/null
66make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install || exit 1
67popd
68
69#strip bins and other stuff
70syn3_strip /tmp/pkg || exit 1
71
72#move development stuff and create seperate development package
73syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
74syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
75
76#make main package
77syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
78
79
80
Note: See TracBrowser for help on using the repository browser.