source: npl/internetserver/pear_PEAR/pear_PEAR.SlackBuild

Last change on this file was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.2 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7
8#######Essential package info.
9#Change these if autodetection fails.
10
11#Name of the Syn-3 package that we are going to create
12NAME=`basename $0|sed 's/.SlackBuild//'`
13
14#Archive of the sourcefiles to unpack
15SRC_ARC=`ls *.tgz`
16
17#Version of the sourcefiles
18VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
19
20#Directory of the sourcefiles to build (after optional unpacking)
21SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
22
23#Architecture that the created binaries run on.
24#Use noarch for scripts.
25ARCH=noarch
26
27
28########Build and create the pacakge.
29
30mkdir -p /tmp/pkg/home/system/peartmp
31cp $SRC_ARC /tmp/pkg/home/system/peartmp || exit 1
32
33mkdir -p /tmp/pkg/etc/postinst.d
34cp post.php_pear /tmp/pkg/etc/postinst.d || exit 1
35chmod +x /tmp/pkg/etc/postinst.d/* || exit 1
36
37#make main package
38syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
39
40
Note: See TracBrowser for help on using the repository browser.