source: npl/internetserver/pecl_mcrypt/pecl_mcrypt.SlackBuild @ 6e790ab

Last change on this file since 6e790ab was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.0 KB
Line 
1#!/bin/bash
2
3#DEP:php5
4##DEP:mcrypt
5#DEP:libmcrypt
6#NEED:mcrypt
7#DEP:libtool
8
9#######Essential package info.
10#Change these if autodetection fails.
11
12#Name of the Syn-3 package that we are going to create
13NAME=`basename $0|sed 's/.SlackBuild//'`
14
15#Archive of the sourcefiles to unpack
16SRC_ARC=`ls *.tar.gz 2>/dev/null`
17
18#Version of the sourcefiles
19VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
20
21#Architecture that the created binaries run on.
22#Use noarch for scripts.
23ARCH=`uname -m`
24
25#from this point on, exit on errors:
26set -e
27
28########Build and create the pacakge.
29#Uncomment the stuff that you dont want or need
30
31#Unpack source
32#(uncomment if not needed)
33syn3_unpack $SRC_ARC
34
35#Directory where the sourcefiles are unpacked.
36#(you might have to adjust this if autodetection fails)
37SRC_DIR=`ls -c|head -1`
38
39PATH=/usr/php5/bin/:$PATH
40pushd $SRC_DIR/ext/mcrypt
41phpize
42aclocal
43
44
45#AUTOMAKE: Configure
46#Some usefull stuff you sometimes need to set:
47#export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/"
48#export LD_LIBRARY_PATH=/usr/lib/mysql
49#export VPATH=$LD_LIBRARY_PATH
50MAKE_OPTS=""
51./configure --prefix=/usr || exit 1
52
53#AUTOMAKE: Compile
54make $MAKE_OPTS || exit 1
55
56#AUTOMAKE: Test (optional)
57#if grep ^test: Makefile; then
58#       make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
59#       make $MAKE_OPTS test || exit 1
60#elif grep ^check: Makefile; then
61#       make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
62#       make $MAKE_OPTS check || exit 1
63#fi
64
65#AUTOMAKE: Install
66mkdir -p /tmp/pkg &>/dev/null
67make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install || exit 1
68popd
69
70mkdir -p /tmp/pkg/etc/php5/
71cp mcrypt.ini /tmp/pkg/etc/php5/  || exit 1
72
73#strip bins and other stuff
74syn3_strip /tmp/pkg || exit 1
75
76#move development stuff and create seperate development package
77syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
78syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
79
80#make main package
81syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
82
83
84
Note: See TracBrowser for help on using the repository browser.