source: npl/internetserver/pecl_memcache/pecl_memcache.SlackBuild @ d6ed36a

perl-5.22
Last change on this file since d6ed36a was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.9 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#DEP:php5
8
9#######Essential package info.
10#Change these if autodetection fails.
11
12#Name of the Syn-3 package that we are going to create
13NAME=`basename $0|sed 's/.SlackBuild//'`
14
15#Archive of the sourcefiles to unpack
16SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
17
18#Version of the sourcefiles
19VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
20
21#Architecture that the created binaries run on.
22#Use noarch for scripts.
23ARCH=`uname -m`
24
25#from this point on, exit on errors:
26set -e
27
28########Build and create the pacakge.
29#Uncomment the stuff that you dont want or need
30
31#Unpack source
32#(uncomment if not needed)
33syn3_unpack $SRC_ARC
34
35#Directory where the sourcefiles are unpacked.
36#(you might have to adjust this if autodetection fails)
37SRC_DIR=`ls -c|head -1`
38
39#apply patches
40#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
41
42pushd $SRC_DIR
43
44#AUTOMAKE: Configure
45#Some usefull stuff you sometimes need to set:
46#export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/"
47#export LD_LIBRARY_PATH=/usr/lib/mysql
48#export VPATH=$LD_LIBRARY_PATH
49MAKE_OPTS=""
50
51/usr/php5/bin/phpize || exit 1
52./configure  --with-php-config=/usr/php5/bin/php-config   || exit 1
53make || exit 1
54
55mkdir /tmp/pkg
56make install INSTALL_ROOT=/tmp/pkg || exit 1
57popd
58
59
60mkdir -p /tmp/pkg/etc/php5/
61echo 'extension=memcache.so' > /tmp/pkg/etc/php5/memcache.ini
62
63
64#strip bins and other stuff
65syn3_strip /tmp/pkg || exit 1
66
67#move development stuff and create seperate development package
68syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
69syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
70
71#make main package
72syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
73
74
75
Note: See TracBrowser for help on using the repository browser.