source: npl/internetserver/pecl_opcache/pecl_opcache.SlackBuild @ e1b2384

perl-5.22
Last change on this file since e1b2384 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.2 KB
Line 
1#!/bin/bash
2#DEP:php5
3
4#######Essential package info.
5#Change these if autodetection fails.
6
7#Name of the Syn-3 package that we are going to create
8NAME=`basename $0|sed 's/.SlackBuild//'`
9
10#Archive of the sourcefiles to unpack
11SRC_ARC=`ls *.tgz 2>/dev/null`
12
13#Version of the sourcefiles
14VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
15
16#Architecture that the created binaries run on.
17#Use noarch for scripts.
18ARCH=`uname -m`
19
20#from this point on, exit on errors:
21set -e
22
23########Build and create the pacakge.
24#Uncomment the stuff that you dont want or need
25
26#Unpack source
27#(uncomment if not needed)
28syn3_unpack $SRC_ARC
29
30#Directory where the sourcefiles are unpacked.
31#(you might have to adjust this if autodetection fails)
32SRC_DIR=`echo $SRC_ARC|sed 's/.tgz//g'`
33
34#apply patches
35#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
36
37pushd $SRC_DIR
38
39PATH=/usr/php5/bin/:$PATH
40phpize
41
42#AUTOMAKE: Configure
43#Some usefull stuff you sometimes need to set:
44#export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/"
45#export LD_LIBRARY_PATH=/usr/lib/mysql
46#export VPATH=$LD_LIBRARY_PATH
47MAKE_OPTS=""
48./configure --prefix=/usr --with-php-config=/usr/php5/bin/php-config || exit 1
49
50#AUTOMAKE: Compile
51make $MAKE_OPTS || exit 1
52
53#AUTOMAKE: Test (optional)
54if grep ^test: Makefile; then
55        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
56        yes -n | make $MAKE_OPTS test || exit 1
57elif grep ^check: Makefile; then
58        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
59        make $MAKE_OPTS check || exit 1
60fi
61
62#AUTOMAKE: Install
63mkdir -p /tmp/pkg &>/dev/null
64make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install || exit 1
65popd
66
67mkdir -p /tmp/pkg/etc/php5/
68cp opcache.ini /tmp/pkg/etc/php5/  || exit 1
69
70mkdir -p /tmp/pkg/etc/postinst.d || exit 1
71cp post.pecl_opcache /tmp/pkg/etc/postinst.d || exit 1
72chmod +x /tmp/pkg/etc/postinst.d/*
73
74
75#strip bins and other stuff
76syn3_strip /tmp/pkg || exit 1
77
78#move development stuff and create seperate development package
79syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
80syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
81
82#make main package
83syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
84
85
86
Note: See TracBrowser for help on using the repository browser.