source: npl/internetserver/pecl_pam/pecl_pam.SlackBuild @ 0c5671f

gcc484ntopperl-5.22
Last change on this file since 0c5671f was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.0 KB
Line 
1#!/bin/bash
2#DEP:php5
3#DEP:Linux_PAM
4
5#######Essential package info.
6#Change these if autodetection fails.
7
8#Name of the Syn-3 package that we are going to create
9NAME=`basename $0|sed 's/.SlackBuild//'`
10
11#Archive of the sourcefiles to unpack
12SRC_ARC=`ls *.tgz 2>/dev/null`
13
14#Version of the sourcefiles
15VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
16
17#Architecture that the created binaries run on.
18#Use noarch for scripts.
19ARCH=`uname -m`
20
21#from this point on, exit on errors:
22set -e
23
24########Build and create the pacakge.
25#Uncomment the stuff that you dont want or need
26
27#Unpack source
28#(uncomment if not needed)
29syn3_unpack $SRC_ARC
30
31#Directory where the sourcefiles are unpacked.
32#(you might have to adjust this if autodetection fails)
33SRC_DIR=pam-1.0.3
34
35#apply patches
36#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
37
38pushd $SRC_DIR
39
40PATH=/usr/php5/bin/:$PATH
41phpize
42
43#AUTOMAKE: Configure
44#Some usefull stuff you sometimes need to set:
45#export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/"
46#export LD_LIBRARY_PATH=/usr/lib/mysql
47#export VPATH=$LD_LIBRARY_PATH
48MAKE_OPTS=""
49./configure --prefix=/usr || exit 1
50
51#AUTOMAKE: Compile
52make $MAKE_OPTS || exit 1
53
54#AUTOMAKE: Test (optional)
55if grep ^test: Makefile; then
56        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
57        make $MAKE_OPTS test || exit 1
58elif grep ^check: Makefile; then
59        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
60        make $MAKE_OPTS check || exit 1
61fi
62
63#AUTOMAKE: Install
64mkdir -p /tmp/pkg &>/dev/null
65make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install || exit 1
66popd
67
68#strip bins and other stuff
69syn3_strip /tmp/pkg || exit 1
70
71#move development stuff and create seperate development package
72syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
73syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
74
75#make main package
76syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
77
78
79
Note: See TracBrowser for help on using the repository browser.