Last change
on this file since f33f781 was
f33f781,
checked in by Edwin Eefting <edwin@datux.nl>, 3 years ago
|
php7 and deps
|
-
Property mode set to
100755
|
File size:
1.0 KB
|
Line | |
---|
1 | #!/bin/bash |
---|
2 | # |
---|
3 | # Automaticly created by importpackage v1.0 |
---|
4 | # Imported from: https://mirrors.slackware.com/slackware/slackware-current/source/n/php/ |
---|
5 | # Created at Wed 01 Jun 2022 01:40:06 PM CEST |
---|
6 | |
---|
7 | #DEP:curl |
---|
8 | |
---|
9 | #DEP:openldap |
---|
10 | #DEP:postgresql |
---|
11 | #DEP:mysql56 |
---|
12 | #DEP:openssl |
---|
13 | #DEP:libmm |
---|
14 | #DEP:libxml2 |
---|
15 | #DEP:libjpeg |
---|
16 | #DEP:libpng |
---|
17 | #DEP:gmp |
---|
18 | #DEP:zlib |
---|
19 | #DEP:bzip2 |
---|
20 | #DEP:Linux_PAM |
---|
21 | |
---|
22 | #NEED:apache_conf |
---|
23 | #DEP:apache2 |
---|
24 | #DEP:apr |
---|
25 | #DEP:apr_util |
---|
26 | #DEP:apache_conf |
---|
27 | |
---|
28 | #DEP:cyrus_sasl |
---|
29 | #DEP:pcre2 |
---|
30 | #DEP:sqlite |
---|
31 | #DEP:gd |
---|
32 | #DEP:icu4c |
---|
33 | #DEP:oniguruma |
---|
34 | #DEP:aspell |
---|
35 | #DEP:libsodium |
---|
36 | #DEP:expat |
---|
37 | #DEP:libxslt |
---|
38 | #DEP:freetype2 |
---|
39 | |
---|
40 | ########### source original slackbuild (hopefully we dont need to modify it) |
---|
41 | CWD=`pwd` |
---|
42 | set -e |
---|
43 | source ./php.SlackBuild.orig |
---|
44 | |
---|
45 | |
---|
46 | ############ make syn3 packages |
---|
47 | cd $CWD |
---|
48 | for PKG in /tmp/package-*; do |
---|
49 | NAME=`echo $PKG| sed 's/.*package-//'| sed 's/-/_/g'` |
---|
50 | |
---|
51 | #seperate dev-package |
---|
52 | syn3_move_dev $PKG $PKG""_dev |
---|
53 | syn3_makepkg $PKG""_dev $NAME""_dev $VERSION $ARCH || exit 1 |
---|
54 | |
---|
55 | #make main package |
---|
56 | syn3_makepkg $PKG $NAME $VERSION $ARCH || exit 1 |
---|
57 | done |
---|
Note: See
TracBrowser
for help on using the repository browser.