source: npl/internetserver/plotnetcfg/plotnetcfg.SlackBuild @ c5c522c

gcc484ntopperl-5.22
Last change on this file since c5c522c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 845 bytes
Line 
1#!/bin/bash
2#NEED:git
3#DEP:jansson
4
5NAME=`basename $0|sed 's/.SlackBuild//'`
6
7
8#Architecture that the created binaries run on.
9#Use noarch for scripts.
10ARCH=`uname -m`
11
12#from this point on, exit on errors:
13set -e
14
15#git clone git://github.com/jbenc/plotnetcfg.git
16pushd plotnetcfg
17
18#Version of the sourcefiles
19VER=`git rev-parse HEAD`
20
21make
22
23#AUTOMAKE: Install
24mkdir -p /tmp/pkg &>/dev/null
25make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install || exit 1
26popd
27
28#strip bins and other stuff
29syn3_strip /tmp/pkg || exit 1
30
31#move development stuff and create seperate development package
32syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
33syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
34
35#make main package
36syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
37
38
39
Note: See TracBrowser for help on using the repository browser.