source: npl/internetserver/privoxy/privoxy.SlackBuild @ 8b8e03e

gcc484ntopperl-5.22
Last change on this file since 8b8e03e was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.8 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#Strict build-dependencies
8#Our package will be automaticly rebuilded if there is a major change in a DEP package.
9#(this is recommended for most dependencys)
10##DEP:linux
11##DEP:linux_src
12##DEP:openldap
13#DEP:libpcre
14
15#Loose build-dependencies
16#The package will be installed in the buildroot during buidling, but no automatic rebuild will occur.
17#(not recommended)
18##NEED:doxygen
19
20
21#######Essential package info.
22#Change these if autodetection fails.
23
24#Name of the Syn-3 package that we are going to create
25NAME=`basename $0|sed 's/.SlackBuild//'`
26
27#Archive of the sourcefiles to unpack
28SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
29
30#Version of the sourcefiles
31VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
32
33#Architecture that the created binaries run on.
34#Use noarch for scripts.
35ARCH=`uname -m`
36
37#from this point on, exit on errors:
38set -e
39
40########Build and create the pacakge.
41#Uncomment the stuff that you dont want or need
42
43#Unpack source
44#(uncomment if not needed)
45syn3_unpack $SRC_ARC
46
47#Directory where the sourcefiles are unpacked.
48#(you might have to adjust this if autodetection fails)
49SRC_DIR=`ls -c|head -1`
50
51#apply patches
52#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
53
54pushd $SRC_DIR
55
56#AUTOMAKE: Configure
57#Some usefull stuff you sometimes need to set:
58#export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/"
59#export LD_LIBRARY_PATH=/usr/lib/mysql
60#export VPATH=$LD_LIBRARY_PATH
61#export CFLAGS="-std=c89"
62#export CFLAGS="-fgnu89-inline" #If "multiple definition of `foo'" Also see http://gcc.gnu.org/gcc-4.3/porting_to.html
63MAKE_OPTS=""
64autoheader
65autoconf
66useradd privoxy
67./configure --prefix=/usr  || exit 1
68
69#AUTOMAKE: Compile
70make $MAKE_OPTS || exit 1
71
72#AUTOMAKE: Test (optional)
73if grep ^test: Makefile; then
74        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
75        make $MAKE_OPTS test || exit 1
76elif grep ^check: Makefile; then
77        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
78        make $MAKE_OPTS check || exit 1
79fi
80
81#AUTOMAKE: Install
82mkdir -p /tmp/pkg &>/dev/null
83make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install || exit 1
84popd
85
86#strip bins and other stuff
87syn3_strip /tmp/pkg || exit 1
88
89#move development stuff and create seperate development package
90syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
91syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
92
93#make main package
94syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
95
96
97
Note: See TracBrowser for help on using the repository browser.