1 | #!/bin/bash |
---|
2 | #Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild |
---|
3 | #Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven. |
---|
4 | #Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden. |
---|
5 | ##################################### Build dependency info: |
---|
6 | #DEP:berkeleydb |
---|
7 | #Strict build-dependencies |
---|
8 | #Our package will be automaticly rebuilded if there is a major change in a DEP package. |
---|
9 | #(this is recommended for most dependencys) |
---|
10 | ##DEP:linux |
---|
11 | ##DEP:linux_src |
---|
12 | ##DEP:openldap |
---|
13 | |
---|
14 | #Loose build-dependencies |
---|
15 | #The package will be installed in the buildroot during buidling, but no automatic rebuild will occur. |
---|
16 | #(not recommended) |
---|
17 | ##NEED:doxygen |
---|
18 | |
---|
19 | #######Essential package info. |
---|
20 | #Change these if autodetection fails. |
---|
21 | |
---|
22 | #Name of the Syn-3 package that we are going to create |
---|
23 | NAME=`basename $0|sed 's/.SlackBuild//'` |
---|
24 | |
---|
25 | #Archive of the sourcefiles to unpack |
---|
26 | SRC_ARC=`ls *.tar.* *.zip 2>/dev/null` |
---|
27 | |
---|
28 | #Version of the sourcefiles |
---|
29 | VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'` |
---|
30 | |
---|
31 | #Architecture that the created binaries run on. |
---|
32 | #Use noarch for scripts. |
---|
33 | ARCH=`uname -m` |
---|
34 | |
---|
35 | #from this point on, exit on errors: |
---|
36 | set -e |
---|
37 | |
---|
38 | ########Build and create the pacakge. |
---|
39 | #Uncomment the stuff that you dont want or need |
---|
40 | |
---|
41 | #Unpack source |
---|
42 | #(uncomment if not needed) |
---|
43 | syn3_unpack $SRC_ARC |
---|
44 | |
---|
45 | #Directory where the sourcefiles are unpacked. |
---|
46 | #(you might have to adjust this if autodetection fails) |
---|
47 | SRC_DIR=`ls -c|head -1` |
---|
48 | |
---|
49 | #apply patches |
---|
50 | #patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1 |
---|
51 | |
---|
52 | pushd $SRC_DIR |
---|
53 | |
---|
54 | #AUTOMAKE: Configure |
---|
55 | #Some usefull stuff you sometimes need to set: |
---|
56 | #export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/" |
---|
57 | #export LD_LIBRARY_PATH=/usr/lib/mysql |
---|
58 | #export VPATH=$LD_LIBRARY_PATH |
---|
59 | MAKE_OPTS="" |
---|
60 | ./configure --prefix=/usr \ |
---|
61 | --libdir=/usr/lib \ |
---|
62 | --with-db-lib=/usr/lib \ |
---|
63 | --localstatedir=/var \ |
---|
64 | --sysconfdir=/home/system \ |
---|
65 | --mandir=/usr/man \ |
---|
66 | --docdir=/usr/doc/dansguardian-$VER \ |
---|
67 | --enable-pcre \ |
---|
68 | --enable-clamd \ |
---|
69 | --enable-commandline \ |
---|
70 | --enable-email \ |
---|
71 | --with-squiduser=nobody \ |
---|
72 | --with-squidgroup=nogroup \ |
---|
73 | --program-prefix="" \ |
---|
74 | --program-suffix="" \ |
---|
75 | --build=$ARCH-SYN3-linux || exit 1 |
---|
76 | |
---|
77 | |
---|
78 | #AUTOMAKE: Compile |
---|
79 | make $MAKE_OPTS || exit 1 |
---|
80 | |
---|
81 | #AUTOMAKE: Test (optional) |
---|
82 | if grep ^test: Makefile; then |
---|
83 | make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1 |
---|
84 | make $MAKE_OPTS test || exit 1 |
---|
85 | elif grep ^check: Makefile; then |
---|
86 | make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1 |
---|
87 | make $MAKE_OPTS check || exit 1 |
---|
88 | fi |
---|
89 | |
---|
90 | #AUTOMAKE: Install |
---|
91 | mkdir -p /tmp/pkg &>/dev/null |
---|
92 | make prefix=/tmp/pkg/usr pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install || exit 1 |
---|
93 | |
---|
94 | install -D -m0644 samples/sample.conf /tmp/pkg/etc/squidguard/squidguard.conf.new || exit 1 |
---|
95 | |
---|
96 | install -d -m0755 /tmp/pkg/var/lib/squidguard || exit 1 |
---|
97 | #install -m0755 /tmp/build/blockedsites /tmp/pkg/var/lib/squidguard |
---|
98 | |
---|
99 | chown -R root.bin /tmp/pkg/usr/bin || exit 1 |
---|
100 | mkdir -p /tmp/pkg/usr/doc/$NAME-$VER/samples || exit 1 |
---|
101 | cp -a samples/sample.conf samples/squidGuard-simple.cgi \ |
---|
102 | samples/squidGuard.cgi doc/*.txt doc/*.html doc/*.gif \ |
---|
103 | /tmp/pkg/usr/doc/$NAME-$VER || exit 1 |
---|
104 | #cp -a /tmp/build/{squidguard.conf.blocksites,blockedsites,squidguard.conf.minimal} /tmp/pkg/usr/doc/$NAME-$VER/samples || exit 1 |
---|
105 | |
---|
106 | |
---|
107 | |
---|
108 | |
---|
109 | popd |
---|
110 | |
---|
111 | #strip bins and other stuff |
---|
112 | syn3_strip /tmp/pkg || exit 1 |
---|
113 | |
---|
114 | #move development stuff and create seperate development package |
---|
115 | syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1 |
---|
116 | syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1 |
---|
117 | |
---|
118 | #make main package |
---|
119 | syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1 |
---|
120 | |
---|
121 | |
---|
122 | |
---|