1 | #!/bin/sh |
---|
2 | |
---|
3 | # Copyright 2008, 2009, 2010 Patrick J. Volkerding, Sebeka, MN, USA |
---|
4 | # All rights reserved. |
---|
5 | # |
---|
6 | # Redistribution and use of this script, with or without modification, is |
---|
7 | # permitted provided that the following conditions are met: |
---|
8 | # |
---|
9 | # 1. Redistributions of this script must retain the above copyright |
---|
10 | # notice, this list of conditions and the following disclaimer. |
---|
11 | # |
---|
12 | # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED |
---|
13 | # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF |
---|
14 | # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO |
---|
15 | # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, |
---|
16 | # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, |
---|
17 | # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; |
---|
18 | # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, |
---|
19 | # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR |
---|
20 | # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF |
---|
21 | # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. |
---|
22 | |
---|
23 | PKGNAM=tcpdump |
---|
24 | VERSION=${VERSION:-$(echo $PKGNAM-*.tar.gz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)} |
---|
25 | BUILD=${BUILD:-1} |
---|
26 | |
---|
27 | # Automatically determine the architecture we're building on: |
---|
28 | if [ -z "$ARCH" ]; then |
---|
29 | case "$( uname -m )" in |
---|
30 | i?86) export ARCH=i586 ;; |
---|
31 | arm*) export ARCH=arm ;; |
---|
32 | # Unless $ARCH is already set, use uname -m for all other archs: |
---|
33 | *) export ARCH=$( uname -m ) ;; |
---|
34 | esac |
---|
35 | fi |
---|
36 | |
---|
37 | NUMJOBS=${NUMJOBS:-" -j7 "} |
---|
38 | |
---|
39 | if [ "$ARCH" = "x86_64" ]; then |
---|
40 | LIBDIRSUFFIX="64" |
---|
41 | else |
---|
42 | LIBDIRSUFFIX="" |
---|
43 | fi |
---|
44 | |
---|
45 | CWD=$(pwd) |
---|
46 | TMP=${TMP:-/tmp} |
---|
47 | PKG=$TMP/package-tcpdump |
---|
48 | |
---|
49 | rm -rf $PKG |
---|
50 | mkdir -p $TMP $PKG |
---|
51 | |
---|
52 | cd $TMP |
---|
53 | rm -rf tcpdump-$VERSION |
---|
54 | |
---|
55 | # To (try to) avoid weird errors, take an axe to this: |
---|
56 | rm -rf $TMP/libpcap-?.?.? |
---|
57 | |
---|
58 | tar xvf $CWD/tcpdump-$VERSION.tar.gz || exit 1 |
---|
59 | cd tcpdump-$VERSION || exit 1 |
---|
60 | find . -type d -name CVS -depth -exec rm -rf {} \; |
---|
61 | chown -R root:root . |
---|
62 | find . \ |
---|
63 | \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \ |
---|
64 | -exec chmod 755 {} \; -o \ |
---|
65 | \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \ |
---|
66 | -exec chmod 644 {} \; |
---|
67 | |
---|
68 | ./configure \ |
---|
69 | --prefix=/usr \ |
---|
70 | --libdir=/usr/lib${LIBDIRSUFFIX} \ |
---|
71 | --mandir=/usr/man \ |
---|
72 | --docdir=/usr/doc/tcpdump-$VERSION \ |
---|
73 | --enable-ipv6 \ |
---|
74 | --build=$ARCH-slackware-linux |
---|
75 | make $NUMJOBS || make || exit 1 |
---|
76 | make install DESTDIR=$PKG || exit 1 |
---|
77 | |
---|
78 | # Strange, two identical files: |
---|
79 | ( cd $PKG/usr/sbin |
---|
80 | rm -f tcpdump |
---|
81 | ln -s tcpdump.$VERSION tcpdump |
---|
82 | ) || exit 1 |
---|
83 | |
---|
84 | mkdir -p $PKG/usr/doc/tcpdump-$VERSION |
---|
85 | cp -a \ |
---|
86 | CHANGES CREDITS INSTALL.txt LICENSE README* VERSION \ |
---|
87 | $PKG/usr/doc/tcpdump-$VERSION |
---|
88 | |
---|
89 | find $PKG | xargs file | grep -e "executable" -e "shared object" \ |
---|
90 | | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null |
---|
91 | |
---|
92 | # Compress man pages |
---|
93 | ( cd $PKG/usr/man |
---|
94 | find . -type f -exec gzip -9 {} \; |
---|
95 | for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done |
---|
96 | ) |
---|
97 | |
---|
98 | mkdir -p $PKG/install |
---|
99 | cat $CWD/slack-desc > $PKG/install/slack-desc |
---|
100 | |
---|
101 | # Build the package: |
---|
102 | cd $PKG |
---|
103 | /sbin/makepkg -l y -c n $TMP/tcpdump-$VERSION-$ARCH-$BUILD.txz |
---|
104 | |
---|