Last change
on this file since 17a9f19 was
c5c522c,
checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago
|
initial commit, transferred from cleaned syn3 svn tree
|
-
Property mode set to
100755
|
File size:
810 bytes
|
Line | |
---|
1 | #!/bin/sh |
---|
2 | |
---|
3 | #set vars |
---|
4 | NAME=`echo $0|cut -f2 -d'.'|cut -f2 -d'/'` |
---|
5 | CWD=`pwd` |
---|
6 | TMP=/$CWD/tmp |
---|
7 | PKG=$TMP/package-$NAME |
---|
8 | rm -rf $PKG |
---|
9 | mkdir -p $PKG |
---|
10 | |
---|
11 | VERSION=1.1a |
---|
12 | ARCH=noarch |
---|
13 | echo "Building: '$NAME-$VERSION-$ARCH'" |
---|
14 | |
---|
15 | #extract |
---|
16 | cd $TMP |
---|
17 | tar xzf $CWD/$NAME-$VERSION.tar.gz || exit 1 |
---|
18 | cd $NAME-$VERSION || exit 1 |
---|
19 | |
---|
20 | #create package in $PKG dir |
---|
21 | mkdir -p $PKG/etc/rc.d || exit 1 |
---|
22 | cp $CWD/rc.shaper $PKG/etc/rc.d || exit 1 |
---|
23 | chown root:root $PKG/etc/rc.d/rc.shaper || exit 1 |
---|
24 | chmod 755 $PKG/etc/rc.d/rc.shaper || exit 1 |
---|
25 | cp $CWD/wshaper.conf $PKG/etc/wshaper.conf.new || exit 1 |
---|
26 | chown root:root $PKG/etc/wshaper.conf.new || exit 1 |
---|
27 | chmod 644 $PKG/etc/wshaper.conf.new || exit 1 |
---|
28 | |
---|
29 | #make package |
---|
30 | cd $PKG |
---|
31 | makepkg -l y -c n $CWD/$NAME.pkg > /dev/null && |
---|
32 | echo $VERSION > $CWD/$NAME.version && |
---|
33 | echo $ARCH > $CWD/$NAME.arch |
---|
34 | |
---|
35 | #cleanup |
---|
36 | rm -r $TMP |
---|
Note: See
TracBrowser
for help on using the repository browser.