source: npl/internetserver/wshaper/wondershaper.SlackBuild @ e1b2384

perl-5.22
Last change on this file since e1b2384 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 810 bytes
Line 
1#!/bin/sh
2
3#set vars
4NAME=`echo $0|cut -f2 -d'.'|cut -f2 -d'/'`
5CWD=`pwd`
6TMP=/$CWD/tmp
7PKG=$TMP/package-$NAME
8rm -rf $PKG
9mkdir -p $PKG
10
11VERSION=1.1a
12ARCH=noarch
13echo "Building: '$NAME-$VERSION-$ARCH'"
14
15#extract
16cd $TMP
17tar xzf $CWD/$NAME-$VERSION.tar.gz || exit 1
18cd $NAME-$VERSION || exit 1
19
20#create package in $PKG dir
21mkdir -p $PKG/etc/rc.d || exit 1
22cp $CWD/rc.shaper $PKG/etc/rc.d || exit  1
23chown root:root $PKG/etc/rc.d/rc.shaper || exit 1
24chmod 755 $PKG/etc/rc.d/rc.shaper || exit 1
25cp $CWD/wshaper.conf $PKG/etc/wshaper.conf.new || exit  1
26chown root:root $PKG/etc/wshaper.conf.new || exit 1
27chmod 644 $PKG/etc/wshaper.conf.new || exit 1
28
29#make package
30cd $PKG
31makepkg -l y -c n $CWD/$NAME.pkg > /dev/null &&
32echo $VERSION > $CWD/$NAME.version &&
33echo $ARCH > $CWD/$NAME.arch
34
35#cleanup
36rm -r $TMP
Note: See TracBrowser for help on using the repository browser.