source: npl/java/java_jdom/java_jdom.SlackBuild @ c5c522c

gcc484ntopperl-5.22
Last change on this file since c5c522c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.3 KB
Line 
1#!/bin/bash
2#DEP:apache_ant
3
4# Standaard java package builder. Theoretisch hoef je niks te veranderen.
5# Gebruik deze voor dingen die een build.sh bevatten.
6
7
8#######Essential package info.
9#Change these if autodetection fails.
10
11#Name of the Syn-3 package that we are going to create
12NAME=`basename $0|sed 's/.SlackBuild//'`
13
14#Archive of the sourcefiles to unpack
15SRC_ARC=`ls *.tar.*`
16
17#Version of the sourcefiles
18VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
19
20#Directory of the sourcefiles to build (after optional unpacking)
21SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
22
23#Architecture that the created binaries run on.
24#Use noarch for scripts.
25ARCH=`uname -m`
26
27JAVA_NAME=`echo $SRC_DIR | sed 's/-.*//'`
28
29########Build and create the pacakge.
30#Uncomment the stuff that you dont want or need
31
32#Unpack source
33#(uncomment if not needed)
34syn3_unpack $SRC_ARC || exit 1
35
36#build and install it
37cd $SRC_DIR || exit 1
38sh build.sh || exit 1
39mkdir -p /tmp/pkg/usr/lib/java/lib
40cd ..
41mv $SRC_DIR/build/*.jar /tmp/pkg/usr/lib/java/lib || exit 1
42
43
44#strip bins and other stuff
45syn3_strip /tmp/pkg || exit 1
46
47#move development stuff and create seperate development package
48syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
49syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
50
51#make main package
52syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
53
54
Note: See TracBrowser for help on using the repository browser.