source: npl/java/java_mail/java_mail.SlackBuild @ c5c522c

gcc484ntopperl-5.22
Last change on this file since c5c522c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 724 bytes
RevLine 
[c5c522c]1#!/bin/bash
2
3#Univsersele java package maker.
4#Je hoeft theoretisch niks te veranderen aan dit script. :)
5
6
7#Name of the Syn-3 package that we are going to create
8NAME=`basename $0|sed 's/.SlackBuild//'`
9
10#Archive of the sourcefiles to unpack
11SRC_ARC=`ls *.zip`
12
13JAVA_NAME=`ls *.zip | sed s/-.*//`
14
15#Version of the sourcefiles
16VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.zip//g'`
17
18#Use noarch for scripts.
19ARCH=noarch
20
21
22mkdir unzip
23cd unzip
24unzip ../*.zip || exit 1
25cd * || exit 1
26
27#move to final destination
28mkdir -p /tmp/pkg/usr/lib/java/lib
29mv *.jar /tmp/pkg/usr/lib/java/lib || exit 1
30mv lib/*.jar /tmp/pkg/usr/lib/java/lib || exit 1
31
32
33cd ../..
34
35#make main package
36syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
37
38
Note: See TracBrowser for help on using the repository browser.