gcc484ntopperl-5.22
Last change
on this file since c5c522c was
c5c522c,
checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago
|
initial commit, transferred from cleaned syn3 svn tree
|
-
Property mode set to
100755
|
File size:
724 bytes
|
Rev | Line | |
---|
[c5c522c] | 1 | #!/bin/bash |
---|
| 2 | |
---|
| 3 | #Univsersele java package maker. |
---|
| 4 | #Je hoeft theoretisch niks te veranderen aan dit script. :) |
---|
| 5 | |
---|
| 6 | |
---|
| 7 | #Name of the Syn-3 package that we are going to create |
---|
| 8 | NAME=`basename $0|sed 's/.SlackBuild//'` |
---|
| 9 | |
---|
| 10 | #Archive of the sourcefiles to unpack |
---|
| 11 | SRC_ARC=`ls *.zip` |
---|
| 12 | |
---|
| 13 | JAVA_NAME=`ls *.zip | sed s/-.*//` |
---|
| 14 | |
---|
| 15 | #Version of the sourcefiles |
---|
| 16 | VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.zip//g'` |
---|
| 17 | |
---|
| 18 | #Use noarch for scripts. |
---|
| 19 | ARCH=noarch |
---|
| 20 | |
---|
| 21 | |
---|
| 22 | mkdir unzip |
---|
| 23 | cd unzip |
---|
| 24 | unzip ../*.zip || exit 1 |
---|
| 25 | cd * || exit 1 |
---|
| 26 | |
---|
| 27 | #move to final destination |
---|
| 28 | mkdir -p /tmp/pkg/usr/lib/java/lib |
---|
| 29 | mv *.jar /tmp/pkg/usr/lib/java/lib || exit 1 |
---|
| 30 | mv lib/*.jar /tmp/pkg/usr/lib/java/lib || exit 1 |
---|
| 31 | |
---|
| 32 | |
---|
| 33 | cd ../.. |
---|
| 34 | |
---|
| 35 | #make main package |
---|
| 36 | syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1 |
---|
| 37 | |
---|
| 38 | |
---|
Note: See
TracBrowser
for help on using the repository browser.