source: npl/java/java_pg_jdbc/java_pg_jdbc.SlackBuild.8 @ 7c410f9

Last change on this file since 7c410f9 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.3 KB
Line 
1#!/bin/bash
2#NEED:apache_ant
3
4#DEZE KUNNEN WE PAS GEBRUIKEN ALS WE POSTGRES VERSIE 8 HEBBEN!
5
6
7
8#######Essential package info.
9#Change these if autodetection fails.
10
11#Name of the Syn-3 package that we are going to create
12NAME=`basename $0|sed 's/.SlackBuild//'`
13
14#Archive of the sourcefiles to unpack
15SRC_ARC=`ls *.tar.*`
16
17#Version of the sourcefiles
18VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
19
20#Directory of the sourcefiles to build (after optional unpacking)
21SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
22
23#Architecture that the created binaries run on.
24#Use noarch for scripts.
25ARCH=`uname -m`
26
27JAVA_NAME=`echo $SRC_DIR | sed 's/-.*//'`
28
29########Build and create the pacakge.
30#Uncomment the stuff that you dont want or need
31
32#Unpack source
33#(uncomment if not needed)
34syn3_unpack $SRC_ARC || exit 1
35
36#build and install it
37cd $SRC_DIR || exit 1
38/usr/lib/ant/bin/ant || exit 1
39mkdir -p /tmp/pkg/usr/lib/java/lib
40mv jars/*.jar /tmp/pkg/usr/lib/java/lib || exit 1
41cd ..
42
43
44
45#strip bins and other stuff
46syn3_strip /tmp/pkg || exit 1
47
48#move development stuff and create seperate development package
49syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
50syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
51
52#make main package
53syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
54
55
Note: See TracBrowser for help on using the repository browser.