source: npl/java/java_xerces/java_xerces.SlackBuild @ c5c522c

gcc484ntopperl-5.22
Last change on this file since c5c522c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.0 KB
Line 
1#!/bin/bash
2#DEP:apache_ant
3
4#######Essential package info.
5#Change these if autodetection fails.
6
7#Name of the Syn-3 package that we are going to create
8NAME=`basename $0|sed 's/.SlackBuild//'`
9
10
11#Version of the sourcefiles
12VER=2_9_0
13
14
15#Architecture that the created binaries run on.
16#Use noarch for scripts.
17ARCH=noarch
18
19JAVA_NAME=`echo $SRC_DIR | sed 's/-.*//'`
20
21########Build and create the pacakge.
22#Uncomment the stuff that you dont want or need
23
24#Unpack source
25#(uncomment if not needed)
26tar -xzf xerces-2_9_0.tar.gz || exit 1
27
28#build and install it
29cd xerces-2_9_0 || exit 1
30tar -xzf ../Xerces-J-tools.2.9.0.tar.gz || exit 1
31sh build.sh jars || exit 1
32mkdir -p /tmp/pkg/usr/lib/java/lib
33mv build/*.jar /tmp/pkg/usr/lib/java/lib || exit 1
34cd ..
35
36
37#strip bins and other stuff
38syn3_strip /tmp/pkg || exit 1
39
40#move development stuff and create seperate development package
41syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
42syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
43
44#make main package
45syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
46
47
Note: See TracBrowser for help on using the repository browser.