source: npl/java/jdk/jdk.SlackBuild @ 37aaf89

Last change on this file since 37aaf89 was ac05c71, checked in by Edwin Eefting <edwin@datux.nl>, 7 years ago

jdk upgrade

  • Property mode set to 100755
File size: 586 bytes
Line 
1#!/bin/bash
2
3#######Essential package info.
4#Change these if autodetection fails.
5
6#Name of the Syn-3 package that we are going to create
7NAME=`basename $0|sed 's/.SlackBuild//'`
8
9#Version of the sourcefiles
10VER=1.8.0_162
11ARCH=i386
12
13mkdir -p /tmp/pkg/usr/lib
14
15tar -xvzf jdk-8u162-linux-i586.tar.gz
16mv jdk1.8.0_162 /tmp/pkg/usr/lib/java || exit 1
17
18
19#move development stuff and create seperate development package
20syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
21syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
22
23#make main package
24syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
25
26
Note: See TracBrowser for help on using the repository browser.